Re: [PATCH] blame: move blame_entry duplication to add_blame_entry()
- From
Jeff King <peff@peff.net>
- Date
- Mar 10, 2017, 08:32 UTC
- Message-ID
- <20170310083238.hjfnkmcgufi3oehq@sigill.intra.peff.net>
- In-Reply-To
- <11b8ad3a-cd3d-2fd6-4b06-b442099c2709@web.de>
On Fri, Mar 10, 2017 at 01:12:59AM +0100, René Scharfe wrote:
> All callers of add_blame_entry() allocate and copy the second argument. > Let the function do it for them, reducing code duplication.
I assume you found this due to the DUPLICATE() discussion elsewhere. Regardless of the results of that discussion, I think this is a nice simplification.
-Peff