git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 2/3] setup_revisions(): swap if/else bodies to make the next step more readable

From
Junio C Hamano <gitster@pobox.com>
Date
Feb 12, 2017, 18:41 UTC
Message-ID
<20170212184132.12375-3-gitster@pobox.com>
In-Reply-To
<20170212184132.12375-1-gitster@pobox.com>

Swap the condition and bodies of an "if (A) do_A else do_B" in setup_revisions() to "if (!A) do_B else do A", to make the change in the the next step easier to read.

No behaviour change is intended in this step.
Signed-off-by: Junio C Hamano <gitster@pobox.com>
---
 revision.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/revision.c b/revision.c
index 4f46b8ba81..eccf1ab695 100644
--- a/revision.c
+++ b/revision.c
@@ -2237,8 +2237,9 @@ int setup_revisions(int argc, const char **argv, struct rev_info *revs, struct s
 			continue;
 		}
 
-
-		if (handle_revision_arg(arg, revs, flags, revarg_opt)) {
+		if (!handle_revision_arg(arg, revs, flags, revarg_opt)) {
+			got_rev_arg = 1;
+		} else {
 			int j;
 			if (seen_dashdash || *arg == '^')
 				die("bad revision '%s'", arg);
@@ -2255,8 +2256,6 @@ int setup_revisions(int argc, const char **argv, struct rev_info *revs, struct s
 			append_prune_data(&prune_data, argv + i);
 			break;
 		}
-		else
-			got_rev_arg = 1;
 	}
 
 	if (prune_data.nr) {
-- 
2.12.0-rc1-212-ga9adfb24fa
Previous: Junio C HamanoNext: Junio C Hamano
Message 14 of 18 in “WIP: allow "-" as a shorthand for "previous branch"”
  1. 0/2 WIP: allow "-" as a shorthand for "previous branch"Siddharth Kannan, Feb 10, 2017
  2. 1/2 revision.c: args starting with "-" might be a revisionSiddharth Kannan, Feb 10, 2017
  3. 2/2 sha1_name: teach get_sha1_1 "-" shorthand for "@{-1}"Siddharth Kannan, Feb 10, 2017
  4. Matthieu MoyFeb 12, 2017
  5. Siddharth KannanFeb 12, 2017
  6. Junio C HamanoFeb 13, 2017
  7. Junio C HamanoFeb 13, 2017
  8. Junio C HamanoFeb 10, 2017
  9. Siddharth KannanFeb 11, 2017
  10. Junio C HamanoFeb 11, 2017
  11. Junio C HamanoFeb 11, 2017
  12. 0/3 prepare for a rev/range that begins with a dashJunio C Hamano, Feb 12, 2017
  13. 1/3 handle_revision_opt(): do not update argv[left++] with an unknown argJunio C Hamano, Feb 12, 2017
  14. 2/3 setup_revisions(): swap if/else bodies to make the next step more readableJunio C Hamano, Feb 12, 2017
  15. 3/3 setup_revisions(): allow a rev that begins with a dashJunio C Hamano, Feb 12, 2017
  16. Siddharth KannanFeb 12, 2017
  17. Junio C HamanoFeb 12, 2017
  18. Siddharth KannanFeb 14, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.