[PATCH 1/2] config.c: rename label unlock_and_out
- From
Nguyễn Thái Ngọc Duy <pclouds@gmail.com>
- Date
- Dec 20, 2016, 09:48 UTC
- Message-ID
- <20161220094836.4131-1-pclouds@gmail.com>
- In-Reply-To
- <20161220094746.GA3917@ash>
There are two ways to unlock a file: commit, or revert. Rename it to commit_and_out to avoid confusion.
Signed-off-by: Nguyễn Thái Ngọc Duy <pclouds@gmail.com> --- config.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/config.c b/config.c index 4973256..505e0d0 100644 --- a/config.c +++ b/config.c @@ -2416,7 +2416,7 @@ int git_config_rename_section_in_file(const char *config_filename, if (!(config_file = fopen(config_filename, "rb"))) { /* no config file means nothing to rename, no error */ - goto unlock_and_out; + goto commit_and_out; } if (fstat(fileno(config_file), &st) == -1) { @@ -2478,7 +2478,7 @@ int git_config_rename_section_in_file(const char *config_filename, } } fclose(config_file); -unlock_and_out: +commit_and_out: if (commit_lock_file(lock) < 0) ret = error_errno("could not write config file %s", config_filename);
-- 2.8.2.524.g6ff3d78