From: Torsten Bögershausen <tboegi@web.de>
Changes since v1:
- Rename earlyout into search_only
- Increase buffer from 2KiB to 16KiB
- s/mask/eol_bits/
- Reduce the "noise"
- Document "split gather_stats() into gather_all_stats()/gather_stats_partly()
Torsten Bögershausen (2):
read-cache: factor out get_sha1_from_index() helper
convert.c: stream and fast search for binary
cache.h | 3 +
convert.c | 191 ++++++++++++++++++++++++++++++++++++++++-------------------
read-cache.c | 29 +++++----
3 files changed, 150 insertions(+), 73 deletions(-)