git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] index-pack: add a helper function to derive .idx/.keep filename

From
Jeff King <peff@peff.net>
Date
Mar 3, 2016, 22:29 UTC
Message-ID
<20160303222902.GB26712@sigill.intra.peff.net>
In-Reply-To
<xmqqsi071bw1.fsf@gitster.mtv.corp.google.com>
On Thu, Mar 03, 2016 at 01:37:18PM -0800, Junio C Hamano wrote:
Show 8 quoted lines
> These are automatically named by replacing .pack suffix in the
> name of the packfile.  Add a small helper to do so, as I'll be
> adding another one soonish.
> 
> Signed-off-by: Junio C Hamano <gitster@pobox.com>
> ---
>  builtin/index-pack.c | 35 +++++++++++++++++------------------
>  1 file changed, 17 insertions(+), 18 deletions(-)

Even without the upcoming "another one", this is a nice readability improvement.

-Peff
Previous: Junio C HamanoNext: Junio C Hamano
Message 4 of 9 in “index-pack: correct --keep[=<msg>]”
  1. index-pack: correct --keep[=<msg>]Junio C Hamano, Mar 3, 2016
  2. Jeff KingMar 3, 2016
  3. index-pack: add a helper function to derive .idx/.keep filenameJunio C Hamano, Mar 3, 2016
  4. Jeff KingMar 3, 2016
  5. index-pack: --clone-bundle optionJunio C Hamano, Mar 3, 2016
  6. Junio C HamanoMar 3, 2016
  7. Jeff KingMar 4, 2016
  8. Jeff KingMar 4, 2016
  9. Eric SunshineMar 3, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.