git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 00/16] Convert parts of refs.c to struct object_id

From
brian m. carlson <sandals@crustytoothpaste.net>
Date
May 3, 2015, 21:45 UTC
Message-ID
<20150503214500.GA214319@vauxhall.crustytoothpaste.net>
In-Reply-To
<553D49EE.4000801@alum.mit.edu>
On Sun, Apr 26, 2015 at 10:26:22PM +0200, Michael Haggerty wrote:
Show 16 quoted lines
> After that, there is one patch for each callsite, rewriting it to use
> for_each_ref natively (which usually entails modifying my_function to
> take an object_id parameter then undoing the wrapper). These patches
> involve a little bit of thought, but not too much. And the results are
> very bisectable because each patch makes a single small change. I also
> suspect it might be easier to rebase and/or merge my patch series, for
> the same reason.
> 
> The end result was very similar to yours, so I am confident that the net
> result of your patch series is correct. But the remaining differences in
> the end results are also interesting. I made a few more changes in the
> neighborhood of the patches, not to mention a few formatting
> improvements in code that I touched. If you compare the tip of my
> branch, above, to the tip of yours (I uploaded that to my repo too, as
> branch "bc-oid-refs"), it may give you some ideas for other code that
> can be changed to object_id.

This is a very interesting approach. I've only just had time to look at it, but I like it.

I agree that it's much more bisectable, although your series has a much larger quantity of patches. I feel like sending an 83-patch series to the list may frighten reviewers away. That's really the only thing preventing me from replacing my series with yours.

Junio, what would you think about such a series? Would you prefer slightly larger patches, one per file, if it meant that we had many fewer patches, or would you prefer a large number of patches touching a single function each?

-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187
Previous: Michael Haggerty
Message 24 of 24 in “Convert parts of refs.c to struct object_id”
  1. 00/16 Convert parts of refs.c to struct object_idbrian m. carlson, Apr 22, 2015
  2. 01/16 refs: convert struct ref_entry to use struct object_idbrian m. carlson, Apr 22, 2015
  3. Stefan BellerApr 23, 2015
  4. brian m. carlsonApr 24, 2015
  5. 02/16 refs: convert for_each_tag_ref to struct object_idbrian m. carlson, Apr 22, 2015
  6. Stefan BellerApr 23, 2015
  7. Jeff KingApr 23, 2015
  8. brian m. carlsonApr 24, 2015
  9. 03/16 refs: convert remaining users of for_each_ref_in to object_idbrian m. carlson, Apr 22, 2015
  10. 04/16 refs: convert for_each_ref_in_submodule to object_idbrian m. carlson, Apr 22, 2015
  11. 05/16 refs: convert head_ref to struct object_idbrian m. carlson, Apr 22, 2015
  12. 06/16 refs: convert for_each_ref_submodule to struct object_idbrian m. carlson, Apr 22, 2015
  13. 07/16 revision: remove unused _oid helper.brian m. carlson, Apr 22, 2015
  14. 08/16 refs: convert for_each_ref to struct object_idbrian m. carlson, Apr 22, 2015
  15. 09/16 refs: convert for_each_replace_ref to struct object_idbrian m. carlson, Apr 22, 2015
  16. 10/16 refs: convert namespaced ref iteration functions to object_idbrian m. carlson, Apr 22, 2015
  17. 11/16 refs: convert for_each_rawref to struct object_id.brian m. carlson, Apr 22, 2015
  18. 12/16 refs: rename do_for_each_ref_oid to do_for_each_refbrian m. carlson, Apr 22, 2015
  19. 13/16 refs: convert for_each_reflog to struct object_idbrian m. carlson, Apr 22, 2015
  20. 14/16 refs: rename each_ref_fn_oid to each_ref_fnbrian m. carlson, Apr 22, 2015
  21. 15/16 Remove unneeded *_oid functions.brian m. carlson, Apr 22, 2015
  22. 16/16 refs: convert struct ref_lock to struct object_idbrian m. carlson, Apr 22, 2015
  23. Michael HaggertyApr 26, 2015
  24. brian m. carlsonMay 3, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.