Re: [PATCH 2/1] apply: reject input that touches outside $cwd
- From
Jeff King <peff@peff.net>
- Date
- Jan 30, 2015, 19:16 UTC
- Message-ID
- <20150130191621.GA30156@peff.net>
- In-Reply-To
- <xmqqegqcccjt.fsf@gitster.dls.corp.google.com>
On Fri, Jan 30, 2015 at 11:07:34AM -0800, Junio C Hamano wrote:
Show 9 quoted lines
> Jeff King <peff@peff.net> writes: > > > It looks like your new --allow-uplevel goes to verify_path(). So this > > isn't just about "..", but it will also protect against applying a patch > > inside ".git". Which seems like a good thing to me, but I wonder if the > > option name is a little misleading. > > True; not just misleading but is incorrect, I would say. > Suggestions?
I think just "--verify-paths" (and "--no-verify-paths", since the former would be the default) might be fine. That leaves the definition of "verify" vague, but I think that's OK. It used to mean "no '..' and no '.git'", and now it has been widened to include "no weird filesystem-specific variants of .git".
If you wanted to avoid the negative being the commonly used option, maybe "--unsafe-paths" (or "--allow-unsafe-paths" if you like verbs).
-Peff