git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 20/23] reflog_expire(): new function in the reference API

From
Stefan Beller <sbeller@google.com>
Date
Dec 8, 2014, 23:32 UTC
Message-ID
<20141208233217.GL25562@google.com>
In-Reply-To
<1417734515-11812-21-git-send-email-mhagger@alum.mit.edu>
On Fri, Dec 05, 2014 at 12:08:32AM +0100, Michael Haggerty wrote:
Show 6 quoted lines
> Move expire_reflog() into refs.c and rename it to reflog_expire().
> Turn the three policy functions into function pointers that are passed
> into reflog_expire(). Add function prototypes and documentation to
> refs.h.
> 
> Signed-off-by: Michael Haggerty <mhagger@alum.mit.edu>
With or without the nits fixed
Reviewed-by: Stefan Beller <sbeller@google.com>
as the nits are not degrading functionality.
Show 6 quoted lines
> ---
>  builtin/reflog.c | 133 +++++++------------------------------------------------
>  refs.c           | 114 +++++++++++++++++++++++++++++++++++++++++++++++
>  refs.h           |  45 +++++++++++++++++++
>  3 files changed, 174 insertions(+), 118 deletions(-)
> 
> +static int expire_reflog_ent(unsigned char *osha1, unsigned char *nsha1,
> +		const char *email, unsigned long timestamp, int tz,
> +		const char *message, void *cb_data)
Nit: According to our Codingguidelines we want to indent it further, so it aligns with
the arguments from the first line.
+static int expire_reflog_ent(unsigned char *osha1, unsigned char *nsha1,
+                             const char *email, unsigned long timestamp, int tz,
+                             const char *message, void *cb_data)
> +	}
> +	return 0;

Why do we need the return value for expire_reflog_ent? The "return 0:" at the very end of the function is the only return I see here.

Show 6 quoted lines
> +enum expire_reflog_flags {
> +	EXPIRE_REFLOGS_DRY_RUN = 1 << 0,
> +	EXPIRE_REFLOGS_UPDATE_REF = 1 << 1,
> +	EXPIRE_REFLOGS_VERBOSE = 1 << 2,
> +	EXPIRE_REFLOGS_REWRITE = 1 << 3
> +};
Sometimes we align the assigned numbers and sometimes we don't in git, so an alternative would be
enum expire_reflog_flags {
     EXPIRE_REFLOGS_DRY_RUN    = 1 << 0,
     EXPIRE_REFLOGS_UPDATE_REF = 1 << 1,
     EXPIRE_REFLOGS_VERBOSE    = 1 << 2,
     EXPIRE_REFLOGS_REWRITE    = 1 << 3
}
Do we have a preference in the coding style on this one?
> + *
> + * reflog_expiry_select_fn -- Called once for each entry in the
> + *     existing reflog. It should return true iff that entry should be
> + *     pruned.
Also I know how we got here, I wonder if we should inverse the logic here
(in a later patch). "select" sounds to me as if the line is selected to keep it.
However the opposite is true. To actually select (keep) the line we need to return
0. Would it make sense to rename this to reflog_expiry_should_prune_fn ?
Previous: Michael HaggertyNext: Michael Haggerty
Message 53 of 63 in “Add reflog_expire() to the references API”
  1. 00/23 Add reflog_expire() to the references APIMichael Haggerty, Dec 4, 2014
  2. 01/23 refs.c: make ref_transaction_create a wrapper for ref_transaction_updateMichael Haggerty, Dec 4, 2014
  3. 02/23 refs.c: make ref_transaction_delete a wrapper for ref_transaction_updateMichael Haggerty, Dec 4, 2014
  4. 03/23 refs.c: add a function to append a reflog entry to a fdMichael Haggerty, Dec 4, 2014
  5. 04/23 expire_reflog(): remove unused parameterMichael Haggerty, Dec 4, 2014
  6. Jonathan NiederDec 4, 2014
  7. Jonathan NiederDec 4, 2014
  8. Michael HaggertyDec 5, 2014
  9. 05/23 expire_reflog(): rename "ref" parameter to "refname"Michael Haggerty, Dec 4, 2014
  10. Jonathan NiederDec 4, 2014
  11. 06/23 expire_reflog(): exit early if the reference has no reflogMichael Haggerty, Dec 4, 2014
  12. Jonathan NiederDec 4, 2014
  13. Jonathan NiederDec 4, 2014
  14. Michael HaggertyDec 5, 2014
  15. 07/23 expire_reflog(): use a lock_file for rewriting the reflog fileMichael Haggerty, Dec 4, 2014
  16. Jonathan NiederDec 5, 2014
  17. Stefan BellerDec 5, 2014
  18. Michael HaggertyDec 8, 2014
  19. Junio C HamanoDec 9, 2014
  20. Jeff KingDec 9, 2014
  21. Stefan BellerDec 5, 2014
  22. Junio C HamanoDec 5, 2014
  23. Stefan BellerDec 5, 2014
  24. Junio C HamanoDec 5, 2014
  25. Michael HaggertyDec 8, 2014
  26. ronnie sahlbergDec 5, 2014
  27. Michael HaggertyDec 8, 2014
  28. 08/23 Extract function should_expire_reflog_ent()Michael Haggerty, Dec 4, 2014
  29. Stefan BellerDec 8, 2014
  30. 09/23 expire_reflog(): extract two policy-related functionsMichael Haggerty, Dec 4, 2014
  31. Stefan BellerDec 5, 2014
  32. 10/23 expire_reflog(): add a "flags" argumentMichael Haggerty, Dec 4, 2014
  33. Stefan BellerDec 8, 2014
  34. 11/23 expire_reflog(): move dry_run to flags argumentMichael Haggerty, Dec 4, 2014
  35. Stefan BellerDec 8, 2014
  36. 12/23 expire_reflog(): move updateref to flags argumentMichael Haggerty, Dec 4, 2014
  37. Stefan BellerDec 8, 2014
  38. 13/23 Rename expire_reflog_cb to expire_reflog_policy_cbMichael Haggerty, Dec 4, 2014
  39. Stefan BellerDec 8, 2014
  40. 14/23 struct expire_reflog_cb: a new callback data typeMichael Haggerty, Dec 4, 2014
  41. Stefan BellerDec 8, 2014
  42. 15/23 expire_reflog(): pass flags through to expire_reflog_ent()Michael Haggerty, Dec 4, 2014
  43. Stefan BellerDec 8, 2014
  44. 16/23 expire_reflog(): move verbose to flags argumentMichael Haggerty, Dec 4, 2014
  45. Stefan BellerDec 8, 2014
  46. 17/23 expire_reflog(): move rewrite to flags argumentMichael Haggerty, Dec 4, 2014
  47. Stefan BellerDec 8, 2014
  48. 18/23 Move newlog and last_kept_sha1 to "struct expire_reflog_cb"Michael Haggerty, Dec 4, 2014
  49. Stefan BellerDec 8, 2014
  50. 19/23 expire_reflog(): treat the policy callback data as opaqueMichael Haggerty, Dec 4, 2014
  51. Stefan BellerDec 8, 2014
  52. 20/23 reflog_expire(): new function in the reference APIMichael Haggerty, Dec 4, 2014
  53. Stefan BellerDec 8, 2014
  54. Michael HaggertyDec 12, 2014
  55. Jeff KingDec 12, 2014
  56. Junio C HamanoDec 12, 2014
  57. 21/23 refs.c: remove unlock_ref/close_ref/commit_ref from the refs apiMichael Haggerty, Dec 4, 2014
  58. 22/23 lock_any_ref_for_update(): inline functionMichael Haggerty, Dec 4, 2014
  59. Stefan BellerDec 8, 2014
  60. Michael HaggertyDec 11, 2014
  61. 23/23 refs.c: don't expose the internal struct ref_lock in the header fileMichael Haggerty, Dec 4, 2014
  62. Junio C HamanoDec 4, 2014
  63. Stefan BellerDec 5, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.