git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 10/16] fast-import: use skip_prefix for parsing input

From
Jeff King <peff@peff.net>
Date
Jun 20, 2014, 05:45 UTC
Message-ID
<20140620054549.GA4623@sigill.intra.peff.net>
In-Reply-To
<CAPig+cTgz1s_68MVT5XgTsM9j=NZnCt3tNX3wBGddEq3nWZgyw@mail.gmail.com>
On Thu, Jun 19, 2014 at 11:19:09PM -0400, Eric Sunshine wrote:
Show 14 quoted lines
> > -               if (starts_with(command_buf.buf, "M "))
> > -                       file_change_m(b);
> > -               else if (starts_with(command_buf.buf, "D "))
> > -                       file_change_d(b);
> > -               else if (starts_with(command_buf.buf, "R "))
> > -                       file_change_cr(b, 1);
> > -               else if (starts_with(command_buf.buf, "C "))
> > -                       file_change_cr(b, 0);
> > -               else if (starts_with(command_buf.buf, "N "))
> > -                       note_change_n(b, &prev_fanout);
> > +               const char *v;
> 
> This declaration of 'v' shadows the 'v' added by patch 8/16 earlier in
> the function.

Thanks. I reordered the patches before sending, so when this one was originally written, there was no "v" at the top-level of the function. I think we can just drop this interior one. The point of the short "v" is that it can be used as a temporary value for prefix matches, so I think we can just reuse the same one.

I tried compiling with -Wshadow (which I don't usually do), but we're not even close to compiling clean there. Some of them are legitimately confusing (e.g., try figuring out "end" in parse_rev_note). But others look just annoying (e.g., complaining that a local "usage" conflicts with the global function). I don't know if we want to put effort into being -Wshadow clean or not.

-Peff
Previous: Eric SunshineNext: Eric Sunshine
Message 22 of 33 in “skip_prefix refactoring and cleanups”
  1. 0/16 skip_prefix refactoring and cleanupsJeff King, Jun 18, 2014
  2. 01/16 parse_diff_color_slot: drop ofs parameterJeff King, Jun 18, 2014
  3. 02/16 daemon: mark some strings as constJeff King, Jun 18, 2014
  4. 03/16 avoid using skip_prefix as a booleanJeff King, Jun 18, 2014
  5. 04/16 refactor skip_prefix to return a booleanJeff King, Jun 18, 2014
  6. Eric SunshineJun 20, 2014
  7. Jeff KingJun 20, 2014
  8. Eric SunshineJun 20, 2014
  9. Jeff KingJun 20, 2014
  10. Junio C HamanoJun 23, 2014
  11. Jeff KingJun 23, 2014
  12. builtin/clone.c: detect a clone starting at a tag correctlyJunio C Hamano, Jun 23, 2014
  13. 05/16 apply: use skip_prefix instead of raw additionJeff King, Jun 18, 2014
  14. 06/16 fast-import: fix read of uninitialized argv memoryJeff King, Jun 18, 2014
  15. 07/16 transport-helper: avoid reading past end-of-stringJeff King, Jun 18, 2014
  16. 08/16 use skip_prefix to avoid magic numbersJeff King, Jun 18, 2014
  17. Junio C HamanoJun 23, 2014
  18. Jeff KingJul 1, 2014
  19. 09/16 use skip_prefix to avoid repeating stringsJeff King, Jun 18, 2014
  20. 10/16 fast-import: use skip_prefix for parsing inputJeff King, Jun 18, 2014
  21. Eric SunshineJun 20, 2014
  22. Jeff KingJun 20, 2014
  23. Eric SunshineJun 20, 2014
  24. 11/16 daemon: use skip_prefix to avoid magic numbersJeff King, Jun 18, 2014
  25. 12/16 stat_opt: check extra strlen callJeff King, Jun 18, 2014
  26. 13/16 fast-import: refactor parsing of spacesJeff King, Jun 18, 2014
  27. 14/16 fetch-pack: refactor parsing in get_ackJeff King, Jun 18, 2014
  28. Eric SunshineJun 20, 2014
  29. 15/16 git: avoid magic number with skip_prefixJeff King, Jun 18, 2014
  30. 16/16 use skip_prefix to avoid repeated calculationsJeff King, Jun 18, 2014
  31. Tanay AbhraJun 19, 2014
  32. 17/16 http-push: refactor parsing of remote object namesJeff King, Jun 19, 2014
  33. Jeff KingJun 19, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.