[PATCH 03/16] avoid using skip_prefix as a boolean
- From
Jeff King <peff@peff.net>
- Date
- Jun 18, 2014, 19:42 UTC
- Message-ID
- <20140618194214.GC22622@sigill.intra.peff.net>
- In-Reply-To
- <20140618194117.GA22269@sigill.intra.peff.net>
There's no point in using:
if (skip_prefix(buf, "foo"))
over
if (starts_with(buf, "foo"))
as the point of skip_prefix is to return a pointer to the data after the prefix. Using starts_with is more readable, and will make refactoring skip_prefix easier.
Signed-off-by: Jeff King <peff@peff.net> --- builtin/fmt-merge-msg.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/builtin/fmt-merge-msg.c b/builtin/fmt-merge-msg.c index 3906eda..72378e6 100644 --- a/builtin/fmt-merge-msg.c +++ b/builtin/fmt-merge-msg.c @@ -298,7 +298,7 @@ static void credit_people(struct strbuf *out, (them->nr == 1 && me && (me = skip_prefix(me, them->items->string)) != NULL && - skip_prefix(me, " <"))) + starts_with(me, " <"))) return; strbuf_addf(out, "\n%c %s ", comment_line_char, label); add_people_count(out, them);
-- 2.0.0.566.gfe3e6b2