git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/3] rename STATUS_FORMAT_NONE to STATUS_FORMAT_DEFAULT

From
Jeff King <peff@peff.net>
Date
Feb 22, 2014, 08:24 UTC
Message-ID
<20140222082418.GD1576@sigill.intra.peff.net>
In-Reply-To
<1393009762-31133-2-git-send-email-rctay89@gmail.com>
On Sat, Feb 22, 2014 at 03:09:20AM +0800, Tay Ray Chuan wrote:
> In f3f47a1 (status: add --long output format option), STATUS_FORMAT_NONE
> was introduced, meaning "the user did not specify anything". Rename this
> to *_DEFAULT to better indicate its meaning.

Hmm. We later introduced STATUS_FORMAT_UNSPECIFIED in 84b4202d. It seems like that is the same thing as the _DEFAULT you are proposing here. Can we collapse them into a single value?

-Peff
Previous: Jeff King
Message 8 of 8 in “make commit --verbose work with --no-status”
  1. 0/3 make commit --verbose work with --no-statusTay Ray Chuan, Feb 21, 2014
  2. 1/3 rename STATUS_FORMAT_NONE to STATUS_FORMAT_DEFAULTTay Ray Chuan, Feb 21, 2014
  3. 2/3 extract setting of wt_status.commitable flag out of wt_status_print_updated()Tay Ray Chuan, Feb 21, 2014
  4. 3/3 make commit --verbose work with --no-statusTay Ray Chuan, Feb 21, 2014
  5. Jeff KingFeb 22, 2014
  6. Tay Ray ChuanFeb 24, 2014
  7. Jeff KingFeb 24, 2014
  8. Jeff KingFeb 22, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.