Re: [PATCH 1/2] Add password parameter to git svn commands and use it when provided instead of defaulting to end-user prompt
- From
Jeff King <peff@peff.net>
- Date
- Oct 25, 2013, 07:24 UTC
- Message-ID
- <20131025072429.GB17029@sigill.intra.peff.net>
- In-Reply-To
- <005DF7EA-CF5A-408F-A145-07F53D836974@gmail.com>
On Mon, Oct 21, 2013 at 07:06:29PM +0200, arnaud brejeon wrote:
> I dont know if you plan to keep GIT_ASKPASS as is, but this > environment variable is not mentioned on git svn documentation and I > guess just a few people know about it. Moreover, the name is > misleading as it handles all the prompts, not only the password one.
Yes, the "askpass" name is a little odd, but it is historical. The calling convention was invented for ssh, who used that name (and we do respect SSH_ASKPASS if it is set). Besides being a lousy name for requesting non-password data, it's also a lousy program for doing it. There's no way for the caller to specify "this is not a password", so the program always hides the characters as they are typed. It's one of the reasons the "git credential" subsystem was invented, which has a more flexible interface.
The askpass variables are documented in "git help credentials". However, the rest of that document does not apply to git-svn, which is unlike the rest of git in the way it handles authentication. So it might or might not make sense to point to it from the git-svn docs. Patches welcome if you want to look into it.
-Peff