git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v6] submodule: add 'deinit' command

From
Heiko Voigt <hvoigt@hvoigt.net>
Date
Mar 6, 2013, 06:52 UTC
Message-ID
<20130306065246.GB4064@sandbox-ub>
In-Reply-To
<7vppzdvoj1.fsf@alter.siamese.dyndns.org>
On Tue, Mar 05, 2013 at 07:45:22AM -0800, Junio C Hamano wrote:
Show 15 quoted lines
> Heiko Voigt <hvoigt@hvoigt.net> writes:
> 
> >> +			if test -z "$force"
> >> +			then
> >> +				git rm -n "$sm_path" ||
> >> +				die "$(eval_gettext "Submodule work tree '\$sm_path' contains local modifications; use '-f' to discard them")"
> >
> > Minor nit. IMO, there is an indentation for the || missing here. Maybe
> > Junio can squash that in on his side?
> 
> Sorry, but I do not see an indentation nit here.  The format looks
> perfectly sane to me and in fact any other indentation would be
> wrong.
> 
> Puzzled...

Wouldn't you write this code snippet like this to make clear that there is another conditional?

	if test -z "$force"
	then
		git rm -n "$sm_path" ||
			die "$(eval_gettext "Submodule work tree '\$sm_path' contains local modifications; use '-f' to discard them")"

It seems it is not clear in the code base either. Some places do some do not indent:

  git grep -A 1 '||' *.sh

Except for the testsuite I just assumed that this style was common, because for me it makes the code much easier to read.

It seems it is not, so forget my comment.
Cheers Heiko
Previous: Junio C HamanoNext: Phil Hord
Message 12 of 21 in “submodule: add 'deinit' command”
  1. submodule: add 'deinit' commandJens Lehmann, Feb 6, 2013
  2. Phil HordFeb 12, 2013
  3. Junio C HamanoFeb 12, 2013
  4. Jens LehmannFeb 13, 2013
  5. Junio C HamanoFeb 13, 2013
  6. submodule: add 'deinit' commandJens Lehmann, Feb 17, 2013
  7. Junio C HamanoFeb 17, 2013
  8. Jens LehmannFeb 18, 2013
  9. submodule: add 'deinit' commandJens Lehmann, Mar 4, 2013
  10. Heiko VoigtMar 5, 2013
  11. Junio C HamanoMar 5, 2013
  12. Heiko VoigtMar 6, 2013
  13. Phil HordMar 12, 2013
  14. Junio C HamanoMar 12, 2013
  15. Jens LehmannMar 18, 2013
  16. Junio C HamanoMar 19, 2013
  17. submodule deinit: clarify work tree removal messageJens Lehmann, Apr 1, 2013
  18. Phil HordApr 16, 2013
  19. submodule deinit: don't output "Cleared directory" when directory is emptyJens Lehmann, Apr 16, 2013
  20. Junio C HamanoApr 17, 2013
  21. Jens LehmannApr 17, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.