Re: [PATCH v3] completion: add new _GIT_complete helper
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- May 5, 2012, 17:44 UTC
- Message-ID
- <20120505174410.GA17937@burratino>
- In-Reply-To
- <CAMP44s2NRMxuvQXk4RyqFYR=oQw_vrJhmbdwtXsrg=eHhGBS2w@mail.gmail.com>
Felipe Contreras wrote:
Show 7 quoted lines
> This is what I propose: > > 1) We name the new function __git_complete; this would be a temporary > name, the function would not be meant to be public > 2) We discuss later what would be the namespace for public functions, > and rename, or add wrappers for them (e.g. _GIT_ps1, _GIT_complete) > 3) We standardize the odd functions: __gitdir -> __git_dir
Sounds excellent to me.
Thanks, Jonathan