Re: [PATCH 2/2] do not stream large files to pack when filters are in use
- From
Jeff King <peff@peff.net>
- Date
- Feb 24, 2012, 20:48 UTC
- Message-ID
- <20120224204810.GC21447@sigill.intra.peff.net>
- In-Reply-To
- <7vehtkyp6i.fsf@alter.siamese.dyndns.org>
On Fri, Feb 24, 2012 at 12:03:17PM -0800, Junio C Hamano wrote:
Show 7 quoted lines
> > - else if (size <= big_file_threshold || type != OBJ_BLOB) > > + else if (size <= big_file_threshold || type != OBJ_BLOB || > > + convert_to_git(path, NULL, 0, NULL, 0)) > > Nice. It would be even nicer to give a readability macro whose name makes > it clear that this is a query (unfortunately we cannot add '?' at the end > of the function name) and not a conversion. Any name suggestions?
Yeah, I cringed a little at all of the NULLs. How about:
int would_convert_to_git(const char *path);
?
> By the way, I tried this with the tip of 'pu' as of last night, and the > result segfaults on me in t1050 (hash-object -w) ;-).
Eek. I ran through "make test" on my finished series without a problem, but it may be a bad interaction with something in "pu", or maybe a heisenbug. I'll investigate.
-Peff