[RFC/PATCH 0/3] Re: cherry-pick/revert error messages
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Nov 20, 2011, 09:46 UTC
- Message-ID
- <20111120094650.GB2278@elie.hsd1.il.comcast.net>
- In-Reply-To
- <CALkWK0=45OwcBoH2TorsgwTbaXjnffVuh0mGxh2+ShN9cuF-=A@mail.gmail.com>
Ramkumar Ramachandra wrote:
> Looks much better! Yes, a series pretty'fying error messages would be > really nice.
Good to hear. Here's a rough one.
I realize patch 1/3 might not be conservative enough, even though there hasn't been much time for people to get used to --reset yet. So I might be sending a second version that treats --reset as a synonym. But please forget I said that when judging this version (i.e., if it looks like a problem, I do want to know).
Thoughts?
Jonathan Nieder (3): revert: rename --reset option to --quit revert: restructure pick_revisions() for clarity revert: improve error message for cherry-pick during cherry-pick
Documentation/git-cherry-pick.txt | 2 +- Documentation/git-revert.txt | 2 +- Documentation/sequencer.txt | 10 +++--- builtin/revert.c | 71 ++++++++++++++++++------------------- sequencer.h | 2 +- t/t3510-cherry-pick-sequence.sh | 10 +++--- t/t7106-reset-sequence.sh | 2 +- 7 files changed, 49 insertions(+), 50 deletions(-)