git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 00/13] Sequencer with continuation features

From
Jonathan Nieder <jrnieder@gmail.com>
Date
Jun 21, 2011, 15:48 UTC
Message-ID
<20110621154808.GE15461@elie>
In-Reply-To
<1308661489-20080-1-git-send-email-artagnon@gmail.com>
Hi,
Ramkumar Ramachandra wrote:
> I think I can safely say that
> I'm quite happy with the general state of this series now.

It's certainly starting to shape up. I'll quickly review the style and commit messages now, since the part I was lobbying for most has been dealt with (hoorah!) and the rest of the substantive part seems to have some potential changes queued up if I understand correctly. In particular, I have high hopes for changes rippling through once tests get added to make the detailed behavior more clear. :)

General rule of thumb about style, especially commit messages: if something looks wrong, it is. Which is to say, the goal is to make the code easy to read and hack on, and part of that means avoiding that moment of surprise that might interfere with someone getting on with the task at hand. If I seem to be not making sense, please as usual do not assume I am right, but think carefully about it and (ideally) gently correct me if I'm wrong.

Okay, on to the patches. The general shape of the series is a little odd --- some die() elimination, removal of globals in preparation for making this a reusable API, and then the title feature that does not rely on any of the patches before it. Still, it makes a kind of sense from the point of view of development:

 1. First, getting to know the API and using that process to come
    up with obvious improvements.
 2. Next, implementing the new feature.

If I had been writing it, I would have rebased the last 4 patches against master as a new series (so they could be integrated more quickly), but I don't mind reading it this way.

Regards, Jonathan

Previous: Jonathan Nieder
Message 47 of 47 in “Sequencer with continuation features”
  1. 00/13 Sequencer with continuation featuresRamkumar Ramachandra, Jun 21, 2011
  2. 01/13 advice: Introduce error_resolve_conflictRamkumar Ramachandra, Jun 21, 2011
  3. Jonathan NiederJun 21, 2011
  4. Junio C HamanoJun 21, 2011
  5. Ramkumar RamachandraJul 2, 2011
  6. Jonathan NiederJul 2, 2011
  7. 02/13 revert: Factor out add_message_to_msg functionRamkumar Ramachandra, Jun 21, 2011
  8. Jonathan NiederJun 21, 2011
  9. Junio C HamanoJun 21, 2011
  10. 03/13 revert: Don't check lone argument in get_encodingRamkumar Ramachandra, Jun 21, 2011
  11. Jonathan NiederJun 21, 2011
  12. 04/13 revert: Propogate errors upwards from do_pick_commitRamkumar Ramachandra, Jun 21, 2011
  13. Jonathan NiederJun 21, 2011
  14. Junio C HamanoJun 21, 2011
  15. Jonathan NiederJun 21, 2011
  16. Junio C HamanoJun 21, 2011
  17. Ramkumar RamachandraJul 2, 2011
  18. 05/13 revert: Eliminate global "commit" variableRamkumar Ramachandra, Jun 21, 2011
  19. Jonathan NiederJun 21, 2011
  20. Junio C HamanoJun 21, 2011
  21. 06/13 revert: Rename no_replay to record_originRamkumar Ramachandra, Jun 21, 2011
  22. 07/13 revert: Introduce struct to keep command-line optionsRamkumar Ramachandra, Jun 21, 2011
  23. Jonathan NiederJun 21, 2011
  24. Junio C HamanoJun 21, 2011
  25. 08/13 revert: Separate cmdline parsing from functional codeRamkumar Ramachandra, Jun 21, 2011
  26. Jonathan NiederJun 21, 2011
  27. 09/13 revert: Catch incompatible command-line options earlyRamkumar Ramachandra, Jun 21, 2011
  28. Jonathan NiederJun 21, 2011
  29. Ramkumar RamachandraJul 2, 2011
  30. Jonathan NiederJul 2, 2011
  31. Jonathan NiederJul 2, 2011
  32. Ramkumar RamachandraJul 2, 2011
  33. Jonathan NiederJul 2, 2011
  34. Jonathan NiederJul 2, 2011
  35. 10/13 revert: Persist data for continuationRamkumar Ramachandra, Jun 21, 2011
  36. Jonathan NiederJun 21, 2011
  37. Junio C HamanoJun 21, 2011
  38. 11/13 revert: Introduce a layer of indirection over pick_commitsRamkumar Ramachandra, Jun 21, 2011
  39. Junio C HamanoJun 21, 2011
  40. 12/13 revert: Introduce skip-all to cleanup sequencer dataRamkumar Ramachandra, Jun 21, 2011
  41. Junio C HamanoJun 21, 2011
  42. Ramkumar RamachandraJul 2, 2011
  43. Miles BaderJul 4, 2011
  44. Ramkumar RamachandraJul 5, 2011
  45. 13/13 revert: Introduce --continue to continue the operationRamkumar Ramachandra, Jun 21, 2011
  46. Jonathan NiederJun 21, 2011
  47. Jonathan NiederJun 21, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.