Re: [PATCH 2/3] bisect: refactor sha1_array into a generic sha1 list
On Fri, May 20, 2011 at 10:14:12AM -0700, Junio C Hamano wrote:
Show 12 quoted lines
> Jeff King <peff@peff.net> writes:
>
> > Yeah, they probably should both be unsigned, and the sorted flag should
> > be a bit-field (not that it saves any space here, but it makes its purpose
> > more clear).
> >
> > Junio, do you mind squashing this into patch 2/3?
>
> I actually do ;-) If you grep for ALLOC_GROW and look at the structures
> they touch, nr/alloc pairs that are integers are the majority in our
> codebase, and I do not see much bikeshedding value in adding more unsigned
> ones to the mix.
OK, no complaint from me on that.
-Peff