git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [RFC] New type of remote helpers

From
Ramkumar Ramachandra <artagnon@gmail.com>
Date
Oct 3, 2010, 17:07 UTC
Message-ID
<20101003170711.GI328@kytes>
In-Reply-To
<20101003151304.GH17084@burratino>
Hi Tom and Jonathan,
Jonathan Nieder writes:
Show 12 quoted lines
> Sverre Rabbelier wrote:
> > On Sun, Oct 3, 2010 at 13:33, Tomas Carnecky <tom@dbservice.com> wrote:
> 
> >> To test this
> >> approach I created a simple remote helper for svn.
> >
> > I guess it suffices as a POC, but I'd have preferred to see
> > collaboration with the people working on git-remote-svn instead
> > (cc-ed).
> 
> Just a quick note: if this approach gets a working remote helper
> in the hands of users faster, I'm all for it.

First off, great work on the fast-import and the remote-helper! I am very impressed with the results.

Show 7 quoted lines
> My only concern is the name: if it is not compatible the planned
> remote helper from the summer of code project, they should probably
> get different names.  Correct me if I'm wrong, but the main
> differences are:
> 
>  - this is scripted and uses local svn working copy operations; the
>    soc project is in C and uses remote access ("replay")

Yes, the name definitely needs to be changed. Maybe name it something along the lines of "local-svn"?

>  - this uses the nice ls-remote output etc.  Ram, do you think this
>    would be easy to use for remote-svn?

This is quite awesome. Yeah, I suppose we can use it for remote-svn as well.

> So, not many differences.  Maybe we can standardize the interface
> and consider them alternate implementations?

This helper can't be merged in until Tom's changes to fast-import are ported to the current fast-import. I just hope that those changes to fast-import don't conflict with the changes git-remote-svn will need. Frankly, I'd rather we work towards a common goal.

-- Ram
Previous: Jonathan Nieder
Message 21 of 21 in “[RFC] New type of remote helpers”
  1. Tomas CarneckyOct 3, 2010
  2. 1/6 Remote helper: accept ':<value> <name>' as a response to 'list'Tomas Carnecky, Oct 3, 2010
  3. Jonathan NiederOct 5, 2010
  4. Sverre RabbelierOct 7, 2010
  5. 2/6 Allow more than one keepfile in the transportTomas Carnecky, Oct 3, 2010
  6. Jonathan NiederOct 5, 2010
  7. 3/6 Allow the transport fetch command to add additional refsTomas Carnecky, Oct 3, 2010
  8. Jonathan NiederOct 5, 2010
  9. 4/6 Rename get_mode() to decode_tree_mode() and export itTomas Carnecky, Oct 3, 2010
  10. Jonathan NiederOct 5, 2010
  11. 5/6 Introduce the git fast-import-helperTomas Carnecky, Oct 3, 2010
  12. Jonathan NiederOct 3, 2010
  13. Tomas CarneckyOct 3, 2010
  14. Sverre RabbelierOct 3, 2010
  15. Tomas CarneckyOct 3, 2010
  16. Sverre RabbelierOct 3, 2010
  17. 6/6 Add git-remote-svnTomas Carnecky, Oct 3, 2010
  18. Jonathan NiederOct 5, 2010
  19. Sverre RabbelierOct 3, 2010
  20. Jonathan NiederOct 3, 2010
  21. Ramkumar RamachandraOct 3, 2010

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.