git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH/RFC 0/2] git-svn: Allow certain refs to be ignored

From
EWEric Wong <normalperson@yhbt.net>
Date
Apr 21, 2010, 16:54 UTC
Message-ID
<20100421165451.GA14004@dcvr.yhbt.net>
In-Reply-To
<m2wc8b3bef91004210931xc0a7ec58ycbf18dd37d5e98f0@mail.gmail.com>
Michael Olson <mwolson@gnu.org> wrote:
Show 13 quoted lines
> On Tue, Apr 20, 2010 at 4:58 PM, Junio C Hamano <gitster@pobox.com> wrote:
> > Michael Olson <mwolson@gnu.org> writes:
> >
> >> [svn-remote "svn"]
> >>        url = https://svn.my.org/svn/root
> >> ...
> >>        ignore-refs = ^refs/remotes/(tags/)?old/myorg
> >
> > Traditionally configuration variable names are spelled camelCase without
> > dashes.  You probably would want to be consistent.
> 
> I was looking at the existing syntax for "ignore-paths", which uses
> dashes.  Should that be changed as well?
Yes, I missed that the first time around :x
I suppose that should be changed to work both ways.
Show 10 quoted lines
> > Also "refs" and any pathname-like things are traditionally matched using
> > globs and not regexes.  It is Ok to deviate if you have a strong reason to
> > (and I suspect it would make it easier to write "exclude" patterns like
> > the above example to allow a regex here), but that needs to be prominently
> > documented (e.g. "Unlike any other ref-matching configuration variable,
> > this alone uses regex, not glob") to avoid end user confusion.
> 
> ignore-paths also uses a regex.  I'm concerned that using globs will
> not be expressive enough to represent a regex like (a combination of
> the 2 use cases I posted initially):
I also missed that (I never used that feature :x)
> ^refs/remotes/((tags/)?old/myorg|old/bad_branch|old/unlabeled[^/]*|tags/(old/bad_tag|releases/another_tag))$

I wonder if both would be better as a series of globs would be easier to read (maybe more verbose to write):

	ignoreRefs = refs/remotes/tags/old/myorg
	ignoreRefs = refs/remotes/old/myorg
	ignoreRefs = refs/remotes/old/unlabeled/*

But I suppose the regexp route is fine. I'll ack and push them out with Sam's Ack on 2/2

-- 
Eric Wong
Previous: Michael OlsonNext: Michael Olson
Message 5 of 7 in “git-svn: Allow certain refs to be ignored”
  1. 0/2 git-svn: Allow certain refs to be ignoredMichael Olson, Apr 20, 2010
  2. Junio C HamanoApr 20, 2010
  3. Eric WongApr 21, 2010
  4. Michael OlsonApr 21, 2010
  5. Eric WongApr 21, 2010
  6. Michael OlsonApr 21, 2010
  7. Eric WongApr 21, 2010

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.