Re: [JGIT PATCH] Rename RevTag.getName() to RevTag.getTagName()
onsdag 12 augusti 2009 21:39:16 skrev "Shawn O. Pearce" <spearce@spearce.org>:
Show 11 quoted lines
> The method getName() conflicts semantically with the method name()
> we have inherited from our base class, ObjectId. It is a rather
> unfortunate turn of events that for performance reasons we wind up
> subclassing what should be a property of this class, but since we
> do that we need to pay attention to the methods declared on our
> base class.
>
> We want to use getName() to be a mirror of name() on AnyObjectId,
> as it has a more JavaBeans style feel to the accessing of that
> particular value. So, rename getTagName() so it doesn't wind up
> conflicting with the SHA-1 hex formatted string.
Show 9 quoted lines
> @@ -204,7 +204,7 @@ public final RevObject getObject() {
> * @return name of the tag, according to the tag header.
> */
> public final String getName() {
> - return name;
> + return tagName;
> }
>
> final void disposeBody() {You forgot the rename of the method here, and all uses of it.
-- robin