git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[JGIT PATCH] Rename RevTag.getName() to RevTag.getTagName()

From
Shawn O. Pearce <spearce@spearce.org>
Date
Aug 12, 2009, 19:39 UTC
Message-ID
<1250105956-17795-1-git-send-email-spearce@spearce.org>

The method getName() conflicts semantically with the method name() we have inherited from our base class, ObjectId. It is a rather unfortunate turn of events that for performance reasons we wind up subclassing what should be a property of this class, but since we do that we need to pay attention to the methods declared on our base class.

We want to use getName() to be a mirror of name() on AnyObjectId, as it has a more JavaBeans style feel to the accessing of that particular value. So, rename getTagName() so it doesn't wind up conflicting with the SHA-1 hex formatted string.

Noticed-by: Alex Blewitt <alex.blewitt@gmail.com>
Signed-off-by: Shawn O. Pearce <spearce@spearce.org>
---
 .../src/org/spearce/jgit/revwalk/RevTag.java       |    8 ++++----
 1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/org.spearce.jgit/src/org/spearce/jgit/revwalk/RevTag.java b/org.spearce.jgit/src/org/spearce/jgit/revwalk/RevTag.java
index 2fab266..51ff49b 100644
--- a/org.spearce.jgit/src/org/spearce/jgit/revwalk/RevTag.java
+++ b/org.spearce.jgit/src/org/spearce/jgit/revwalk/RevTag.java
@@ -56,7 +56,7 @@
 
 	private byte[] buffer;
 
-	private String name;
+	private String tagName;
 
 	/**
 	 * Create a new tag reference.
@@ -96,7 +96,7 @@ void parseCanonical(final RevWalk walk, final byte[] rawTag)
 
 		int p = pos.value += 4; // "tag "
 		final int nameEnd = RawParseUtils.nextLF(rawTag, p) - 1;
-		name = RawParseUtils.decode(Constants.CHARSET, rawTag, p, nameEnd);
+		tagName = RawParseUtils.decode(Constants.CHARSET, rawTag, p, nameEnd);
 
 		if (walk.isRetainBody())
 			buffer = rawTag;
@@ -186,7 +186,7 @@ public final String getShortMessage() {
 	 * @return parsed tag.
 	 */
 	public Tag asTag(final RevWalk walk) {
-		return new Tag(walk.db, this, name, buffer);
+		return new Tag(walk.db, this, tagName, buffer);
 	}
 
 	/**
@@ -204,7 +204,7 @@ public final RevObject getObject() {
 	 * @return name of the tag, according to the tag header.
 	 */
 	public final String getName() {
-		return name;
+		return tagName;
 	}
 
 	final void disposeBody() {
-- 
1.6.4.225.gb589e
Next: Robin Rosenberg
Message 1 of 3 in “Rename RevTag.getName() to RevTag.getTagName()”
  1. Rename RevTag.getName() to RevTag.getTagName()Shawn O. Pearce, Aug 12, 2009
  2. Robin RosenbergAug 12, 2009
  3. Rename RevTag.getName() to RevTag.getTagName()Shawn O. Pearce, Aug 12, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.