Re: [EGIT PATCH] Provide a more JavaBeans-style 'getName' accessor for the id Signed-off-by: Alex Blewitt <alex.blewitt@gmail.com>
- From
Shawn O. Pearce <spearce@spearce.org>
- Date
- Aug 12, 2009, 14:20 UTC
- Message-ID
- <20090812142049.GA1033@spearce.org>
- In-Reply-To
- <8ACC6C83-75FD-477C-9083-96CA426FC069@gmail.com>
Alex Blewitt <alex.blewitt@gmail.com> wrote:
Show 12 quoted lines
> On 10 Aug 2009, at 21:59, "Shawn O." <spearce@spearce.org> wrote: >> >>>> ./org/spearce/jgit/revwalk/RevTag.java:206: getName() in >>>> org.spearce.jgit.revwalk.RevTag cannot override getName() in >>>> org.spearce.jgit.lib.AnyObjectId; overridden method is final >> >> I can't apply this patch because getName() on RevTag is already >> defined with a different meaning. :-( > > That sounds dangerous. We now have a .name() and a .getName() with > different semantics. Can we not change the RevTag method name to > something else so that we dont have an inconsistency?
Good point. We didn't think that RevTag.getName method through very well. Rename it to getTagName() ?
-- Shawn.