git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [JGIT PATCH v2 00/11] WindowCache rewrite... with tests

From
Robin Rosenberg <robin.rosenberg.lists@dewire.com>
Date
Apr 29, 2009, 23:46 UTC
Message-ID
<200904300146.31062.robin.rosenberg.lists@dewire.com>
In-Reply-To
<1241031288-23437-1-git-send-email-spearce@spearce.org>
onsdag 29 april 2009 20:54:37 skrev "Shawn O. Pearce" <spearce@spearce.org>:
Show 7 quoted lines
> 9-11 is the rewrite of WindowCache, with new unit tests to get higher
> levels of coverage in this section of the code.  Actually doing
> better is really hard, as we'd need to cause thread race conditions
> deep within critical sections.  The only way I can think to do that
> is to add injection points where we can insert "evil other thread"
> logic during the unit test, and rely on the JIT to compile them
> out in normal application usage.  Ick.  Its also quite fragile.

Testing *is* hard. No news here. There are various techniques for injecting code using AOP (AspjectJ) that may be useful for testing, since we could inject failures that way without the overhead of injection points in normal execution.

-- robin
Previous: Shawn O. Pearce
Message 13 of 13 in “WindowCache rewrite... with tests”
  1. 00/11 WindowCache rewrite... with testsShawn O. Pearce, Apr 29, 2009
  2. 01/11 Fix more computation of integer average overflowsShawn O. Pearce, Apr 29, 2009
  3. 02/11 Fix performance problem recently introduced to DeltaPackedObjectLoaderShawn O. Pearce, Apr 29, 2009
  4. 03/11 Replace inefficient new String(String) constructor to silence FindBugsShawn O. Pearce, Apr 29, 2009
  5. 04/11 Replace inefficient new Long(long) constructor to silence FindBugsShawn O. Pearce, Apr 29, 2009
  6. 05/11 Change IndexPack to use ObjectIdSubclassMap instead of ObjectIdMapShawn O. Pearce, Apr 29, 2009
  7. 06/11 Use getCachedBytes in IndexPack to avoid an unnecessary copyShawn O. Pearce, Apr 29, 2009
  8. 07/11 Remove ObjectIdMap from the JGit libraryShawn O. Pearce, Apr 29, 2009
  9. 08/11 Don't use ByteWindows when checking pack file headers/footersShawn O. Pearce, Apr 29, 2009
  10. 09/11 Rewrite WindowCache to be easier to follow and maintainShawn O. Pearce, Apr 29, 2009
  11. 10/11 Add tests for WindowCache.reconfigure casesShawn O. Pearce, Apr 29, 2009
  12. 11/11 Add tests to increase coverage of WindowCacheShawn O. Pearce, Apr 29, 2009
  13. Robin RosenbergApr 29, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.