Re: [PATCH v1 1/3] Introduce config variable "diff.primer"
- From
Jeff King <peff@peff.net>
- Date
- Jan 25, 2009, 22:11 UTC
- Message-ID
- <20090125221141.GA17490@coredump.intra.peff.net>
- In-Reply-To
- <alpine.GSO.2.00.0901251033160.12651@kiwi.cs.ucla.edu>
On Sun, Jan 25, 2009 at 10:44:25AM -0800, Keith Cascio wrote:
> The name "primer" is open to discussion, of course. But I like it. > From Merriam-Webster: > primer n 1: a device for priming 2: material used in priming a surface > prime vb 1: fill, load 2: to prepare for firing 3: to apply the first color, coating or preparation to <~ a wall>
FWIW, I found it very confusing. I would have expected "diff.options" or "diff.defaults". There is also some precedent in the form of GIT_DIFF_OPTS, but I believe it _only_ handles --unified and -u, so it is not necessarily a useful model.
-Peff