Re: [RFC] Adding a challenge-response authentication method to git://
- From
Stephen R. van den Berg <srb@cuci.nl>
- Date
- Aug 14, 2008, 09:51 UTC
- Message-ID
- <20080814095137.GF9680@cuci.nl>
- In-Reply-To
- <48A3F7AA.8070001@op5.se>
Andreas Ericsson wrote:
>I'd do it like this instead:
>daemon: auth_user = dlsym(dlopen("auth-module.so", RTLD_NOW),
>"authenticat");>This approach has several nifty benefits: >* The otherwise duplicated code (for different auth schemes) is > done only once (in the git daemon).
I'd prefer that to be in a separate program, instead of git-daemon proper.
>* If the git daemon has no authentication module loaded, we might > as well not bother sending any challenge and just pretend we do > not know about the authentication scheme.
Loading modules is highly fragile across different OSes, so it's not really recommended at all.
>* Modules is a great way for newcomers to get started contributing to > git so it's a nice way of getting more contributors/sub-maintainers.
If by "modules" you mean dynamically loaded libraries, then I wholeheartedly disagree.
--
Sincerely,
Stephen R. van den Berg.
"Hold still, while I inject you with SQL."