Re: [PATCH 3/5] Make verbosity configurable in reset_index_file()
- From
Miklos Vajna <vmiklos@frugalware.org>
- Date
- May 27, 2008, 14:49 UTC
- Message-ID
- <20080527144919.GJ27724@genesis.frugalware.org>
- In-Reply-To
- <1211897281.13838.1.camel@gaara.bos.redhat.com>
On Tue, May 27, 2008 at 10:08:01AM -0400, Kristian H?gsberg <krh@redhat.com> wrote:
Show 11 quoted lines
> > -int reset_index_file(const unsigned char *sha1, int is_hard_reset) > > +int reset_index_file(const unsigned char *sha1, int is_hard_reset, int verbose) > > I would suggest using flags here instead of a bunch of boolean args. > Consider the readability of > > reset_index_file(sha1, 1, 1); > > vs > > reset_index_file(sha1, RESET_HARD | RESET_VERBOSE);
Thanks for the suggestion, but - as Daniel already pointed out - the same functionality can be achieved by using the unpack_trees() API directly, so the patch is useless.