Re: [PATCH] Reuse previous annotation when overwriting a tag
- From
Mike Hommey <mh@glandium.org>
- Date
- Nov 3, 2007, 13:59 UTC
- Message-ID
- <20071103135954.GA26204@glandium.org>
- In-Reply-To
- <Pine.LNX.4.64.0711031321320.4362@racer.site>
On Sat, Nov 03, 2007 at 01:22:44PM +0000, Johannes Schindelin wrote:
Show 30 quoted lines
> Hi, > > On Sat, 3 Nov 2007, Mike Hommey wrote: > > > On Sat, Nov 03, 2007 at 12:36:36PM +0000, Johannes Schindelin wrote: > > > > > On Sat, 3 Nov 2007, Mike Hommey wrote: > > > > > > > On Sat, Nov 03, 2007 at 11:54:38AM +0000, Johannes Schindelin wrote: > > > > > Why not teach write_annotations() (or write_tag_body() like I > > > > > would prefer it to be called) to grok a null_sha1? It's not like > > > > > we care for performance here, but rather for readability and ease > > > > > of use. > > > > > > > > By the way, I think it would be much better if this function was > > > > made more generic and would not write, but return an strbuf > > > > containing the object body. It could also be used by e.g. git-commit > > > > --amend. > > > > > > > > What would be the best suited place for such a function ? > > > > > > editor.c, I'd say. > > > > On which topic is this ? > > On none so far. But the plan was to move some functions used by both > builtin-tag and builtin-commit (such as launch_editor()) into the files > editor.[ch]. > > Unfortunately, that plan has not been executed by anybody. Yet.
Anyways, I took a quick glance at builtin-commit.c on pu, and it doesn't look like it would benefit from having a shared function to get the commit body. So I'll just forget about this idea for now.
Mike