git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 0/6] rebase -i: add config to abbreviate command-names

From
Liam Beguin <liambeguin@gmail.com>
Date
May 2, 2017, 23:56 UTC
Message-ID
<1493769381.29673.39.camel@gmail.com>
In-Reply-To
<alpine.DEB.2.20.1705021741580.3480@virtualbox>
Hi Johannes, 
On Tue, 2017-05-02 at 17:48 +0200, Johannes Schindelin wrote:
Show 30 quoted lines
> Hi Liam,
> 
> On Tue, 2 May 2017, Liam Beguin wrote:
> 
> > Add the 'rebase.abbreviateCommands' configuration option to allow `git
> > rebase -i` to default to the single-letter command-names in the todo
> > list.
> > 
> > Using single-letter command-names can present two benefits.  First, it
> > makes it easier to change the action since you only need to replace a
> > single character (i.e.: in vim "r<character>" instead of
> > "ciw<character>").  Second, using this with a large enough value of
> > 'core.abbrev' enables the lines of the todo list to remain aligned
> > making the files easier to read.
> > 
> > Changes from v1 to v2:
> >  - Improve Documentation and commit message
> > 
> > Changes from v2 to v3:
> >  - Transform a single patch into a series
> >  - change option name from 'rebase.abbrevCmd' to 'rebase.abbreviateCommands'
> >  - abbreviate all commands (not just pick)
> >  - teach `git rebase -i --autosquash` to recognise single-letter command-names
> >  - move rebase configuration documentation to Documentation/rebase-config.txt
> >  - update Documentation to use the preferred naming for the todo list
> >  - update Documentation and commit messages according to feedback
> 
> Thank you for this pleasant read. It is an excellent contribution, and the
> way you communicate what you changed and why is very welcome.
> 
Thanks! and thank you for the support and help.
Show 7 quoted lines
> I offered a couple of comments, my biggest one probably being that this
> patch series is crossing paths with my patch series that tries to move
> more functionality out of the git-rebase--interactive.sh script into the
> git-rebase--helper that is written in C, closely followed by my suggestion
> to fold at least part of the functionality into the SHA-1
> collapsing/expanding.
> 

I've seen a few messages about this migration, but I'm not yet sure I understand the difference between the shell and the C implementations. Is the C version going to replace 'git-rebase--interactive.sh'?

Show 6 quoted lines
> If your patch series "wins", I can easily forward-port your changes to the
> rebase-i-extra branch, but it may actually make sense to build on top of
> the rebase-i-extra branch to begin with. If you agree: I pushed the
> proposed change to the `rebase-i-extra+abbrev` branch at
> https://github.com/dscho/git.
> 

If 'git-rebase--interactive.sh' is bound to be replaced, I could just shrink this to the Documentation cleanup (patches 4 and 5) and rework the rest on top of your new implementation.

> I look forward to see this story unfold!
> 
> Ciao,
> Johannes

Thanks, Liam

Previous: Johannes SchindelinNext: Johannes Schindelin
Message 16 of 21 in “rebase -i: add config to abbreviate command-names”
  1. 0/6 rebase -i: add config to abbreviate command-namesLiam Beguin, May 2, 2017
  2. 1/6 rebase -i: add abbreviated command-names handlingLiam Beguin, May 2, 2017
  3. Johannes SchindelinMay 2, 2017
  4. 2/6 rebase -i: add abbreviate_commands functionLiam Beguin, May 2, 2017
  5. Johannes SchindelinMay 2, 2017
  6. 3/6 rebase -i: add short command-name in --autosquashLiam Beguin, May 2, 2017
  7. Johannes SchindelinMay 2, 2017
  8. Liam BeguinMay 2, 2017
  9. 6/6 Documentation: document the rebase.abbreviateCommands optionLiam Beguin, May 2, 2017
  10. 4/6 Documentation: move rebase.* config variables to a separate rebase-config.txtLiam Beguin, May 2, 2017
  11. Johannes SchindelinMay 2, 2017
  12. 5/6 Documentation: use preferred name for the 'todo list' scriptLiam Beguin, May 2, 2017
  13. Ævar Arnfjörð BjarmasonMay 2, 2017
  14. Johannes SchindelinMay 2, 2017
  15. Johannes SchindelinMay 2, 2017
  16. Liam BeguinMay 2, 2017
  17. Johannes SchindelinMay 3, 2017
  18. Junio C HamanoMay 4, 2017
  19. Liam BeguinMay 7, 2017
  20. Junio C HamanoMay 8, 2017
  21. Liam BeguinMay 8, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.