From: Liam Beguin Date: Tue, 02 May 2017 23:56:21 GMT Subject: Re: [PATCH v3 0/6] rebase -i: add config to abbreviate command-names Message-ID: <1493769381.29673.39.camel@gmail.com> In-Reply-To: Hi Johannes, On Tue, 2017-05-02 at 17:48 +0200, Johannes Schindelin wrote: > Hi Liam, > > On Tue, 2 May 2017, Liam Beguin wrote: > > > Add the 'rebase.abbreviateCommands' configuration option to allow `git > > rebase -i` to default to the single-letter command-names in the todo > > list. > > > > Using single-letter command-names can present two benefits.  First, it > > makes it easier to change the action since you only need to replace a > > single character (i.e.: in vim "r" instead of > > "ciw").  Second, using this with a large enough value of > > 'core.abbrev' enables the lines of the todo list to remain aligned > > making the files easier to read. > > > > Changes from v1 to v2: > >  - Improve Documentation and commit message > > > > Changes from v2 to v3: > >  - Transform a single patch into a series > >  - change option name from 'rebase.abbrevCmd' to 'rebase.abbreviateCommands' > >  - abbreviate all commands (not just pick) > >  - teach `git rebase -i --autosquash` to recognise single-letter command-names > >  - move rebase configuration documentation to Documentation/rebase-config.txt > >  - update Documentation to use the preferred naming for the todo list > >  - update Documentation and commit messages according to feedback > > Thank you for this pleasant read. It is an excellent contribution, and the > way you communicate what you changed and why is very welcome. > Thanks! and thank you for the support and help. > I offered a couple of comments, my biggest one probably being that this > patch series is crossing paths with my patch series that tries to move > more functionality out of the git-rebase--interactive.sh script into the > git-rebase--helper that is written in C, closely followed by my suggestion > to fold at least part of the functionality into the SHA-1 > collapsing/expanding. > I've seen a few messages about this migration, but I'm not yet sure I understand the difference between the shell and the C implementations. Is the C version going to replace 'git-rebase--interactive.sh'? > If your patch series "wins", I can easily forward-port your changes to the > rebase-i-extra branch, but it may actually make sense to build on top of > the rebase-i-extra branch to begin with. If you agree: I pushed the > proposed change to the `rebase-i-extra+abbrev` branch at > https://github.com/dscho/git. > If 'git-rebase--interactive.sh' is bound to be replaced, I could just shrink this to the Documentation cleanup (patches 4 and 5) and rework the rest on top of your new implementation. > I look forward to see this story unfold! > > Ciao, > Johannes Thanks, Liam