Changes v4 -> v5:
- Patch #5: Reorder code to ease readability and fix issue with
checking d.given after free_note_data(&d), noticed by Junio.
- Patch #9: Fix typo in commit message, noticed by Junio.
- Patch #9: Rename "output" files to "actual", suggested by Eric.
- Patch #9: Use test_line_count instead of wc -l, which behaves
differently on Macs. noticed by Michael, diagnosed by Eric, and
fix suggested by Peff.
- Patch #9: Use -r option to ls-tree when counting entries in notes,
tree as this also works for trees with fanout level > 0. Noticed
by Peff.
Have fun! :)
...Johan
Johan Herland (9):
builtin/notes: Fix premature failure when trying to add the empty blob
t3301: Verify that 'git notes' removes empty notes by default
builtin/notes: Improve naming
builtin/notes: Refactor note file path into struct note_data
builtin/notes: Simplify early exit code in add()
builtin/notes: Split create_note() to clarify add vs. remove logic
builtin/notes: Add --allow-empty, to allow storing empty notes
notes: Empty notes should be shown by 'git log'
t3301: Modernize
Documentation/git-notes.txt | 12 +-
builtin/notes.c | 258 +++++----
notes.c | 3 +-
t/t3301-notes.sh | 1341 +++++++++++++++++++++----------------------
4 files changed, 789 insertions(+), 825 deletions(-)