git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 3/3] tag: support configuring --sort via .gitconfig

From
Keller, Jacob E <jacob.e.keller@intel.com>
Date
Jul 15, 2014, 14:52 UTC
Message-ID
<1405435933.9147.1.camel@jekeller-desk1.amr.corp.intel.com>
In-Reply-To
<xmqqfvi3zwp7.fsf@gitster.dls.corp.google.com>
On Mon, 2014-07-14 at 10:17 -0700, Junio C Hamano wrote:
Show 31 quoted lines
> Jeff King <peff@peff.net> writes:
> 
> > On Sun, Jul 13, 2014 at 01:33:56PM -0400, Jeff King wrote:
> >
> >> I realize that I am reinventing the error-reporting wheel on a sleepy
> >> Sunday afternoon without having thought about it much, so there is
> >> probably some gotcha or case that makes this ugly, or perhaps it just
> >> ends up verbose in practice. But one can dream.
> >
> > Just for fun...
> 
> Yes, that is fun.
> 
> I actually think your "In 'version:pefname' and 'wersion:refname',
> we want be able to report 'pefname' and 'wersion' are misspelled,
> and returning -1 or enum would not cut it" is a good argument.  The
> callee wants to have flexibility on _what_ to report, just as the
> caller wants to have flexibility on _how_.  In this particular code
> path, I think the former far outweighs the latter, and my suggestion
> I called "silly" might not be so silly but may have struck the right
> balance.  I dunno.
> 
> If you absolutely need to have both, you would need something like
> your approach, of course, but I am not sure if it is worth it.
> 
> I am not sure how well this meshes with i18n (I know the "for fun"
> does not even attempt to, but if we tried to, I suspect it may
> become even uglier).  We would also need to override both error and
> warning routines and have the reporter tag the errors in these two
> categories, no?
> 

Do we want to go this way? Should I respin my patch (again)? I'm not sure we really need to get that complex.. I do like parsing errors a bit cleaner and indicating what part is bad.. Note that our current parsing method does not make it really possible to indicate which part is wrong.

Thanks, Jake

Previous: Junio C HamanoNext: Junio C Hamano
Message 9 of 19 in “tag: use skip_prefix instead of magic numbers”
  1. 1/3 tag: use skip_prefix instead of magic numbersJacob Keller, Jul 11, 2014
  2. 2/3 tag: fix --sort tests to use cat<<-\EOF formatJacob Keller, Jul 11, 2014
  3. 3/3 tag: support configuring --sort via .gitconfigJacob Keller, Jul 11, 2014
  4. Eric SunshineJul 13, 2014
  5. Junio C HamanoJul 13, 2014
  6. Jeff KingJul 13, 2014
  7. Jeff KingJul 13, 2014
  8. Junio C HamanoJul 14, 2014
  9. Keller, Jacob EJul 15, 2014
  10. Junio C HamanoJul 15, 2014
  11. Keller, Jacob EJul 15, 2014
  12. Junio C HamanoJul 15, 2014
  13. Keller, Jacob EJul 15, 2014
  14. Junio C HamanoJul 15, 2014
  15. Keller, Jacob EJul 15, 2014
  16. Keller, Jacob EJul 15, 2014
  17. Junio C HamanoJul 15, 2014
  18. Jeff KingJul 15, 2014
  19. Jeff KingJul 12, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.