[PATCH 1/2] sequencer.c: check for lock failure and bail early in fast_forward_to
- From
Ronnie Sahlberg <sahlberg@google.com>
- Date
- Apr 15, 2014, 23:46 UTC
- Message-ID
- <1397605608-12128-2-git-send-email-sahlberg@google.com>
- In-Reply-To
- <1397605608-12128-1-git-send-email-sahlberg@google.com>
Change fast_forward_to() to check if locking the ref failed, print a nice error message and bail out early. The old code did not check if ref_lock was NULL and relied on the fact that the write_ref_sha1() would safely detect this condition and set the return variable ret to indicate an error. While that is safe, it makes the code harder to read for two reasons: * Inconsistency. Almost all other places we do check the lock for NULL explicitely, so the naive reader is confused "why don't we check here". * And relying on write_ref_sha1() to detect and return an error for when a previous lock_any_ref_for_update() feels obfuscated.
This change should not change any functionality or logic aside from adding an extra error message when this condition is triggered. (write_ref_sha1() returns an error silently for this condition)
Signed-off-by: Ronnie Sahlberg <sahlberg@google.com> --- sequencer.c | 7 +++++++ 1 file changed, 7 insertions(+)
diff --git a/sequencer.c b/sequencer.c index bde5f04..6aa3b50 100644 --- a/sequencer.c +++ b/sequencer.c @@ -281,8 +281,15 @@ static int fast_forward_to(const unsigned char *to, const unsigned char *from, exit(1); /* the callee should have complained already */ ref_lock = lock_any_ref_for_update("HEAD", unborn ? null_sha1 : from, 0, NULL); + if (!ref_lock) { + ret = error(_("Failed to lock HEAD during fast_forward_to")); + goto leave; + } + strbuf_addf(&sb, "%s: fast-forward", action_name(opts)); ret = write_ref_sha1(ref_lock, to, sb.buf); + +leave: strbuf_release(&sb); return ret; }
-- 1.9.1.503.ge4c3920.dirty