git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v2 2/3] Add size parameter to read_blob_data_from_index_path()

From
LFLukas Fleischer <git@cryptocrack.de>
Date
Apr 13, 2013, 13:28 UTC
Message-ID
<1365859712-8400-2-git-send-email-git@cryptocrack.de>
In-Reply-To
<1365859712-8400-1-git-send-email-git@cryptocrack.de>

This allows for optionally getting the size of the returned data and will be used in a follow-up patch.

Signed-off-by: Lukas Fleischer <git@cryptocrack.de>
---
 attr.c       | 2 +-
 cache.h      | 2 +-
 read-cache.c | 5 ++++-
 3 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/attr.c b/attr.c
index 08347b6..17338c8 100644
--- a/attr.c
+++ b/attr.c
@@ -387,7 +387,7 @@ static struct attr_stack *read_attr_from_index(const char *path, int macro_ok)
 	char *buf, *sp;
 	int lineno = 0;
 
-	buf = read_blob_data_from_index_path(path, use_index);
+	buf = read_blob_data_from_index_path(path, use_index, NULL);
 	if (!buf)
 		return NULL;
 
diff --git a/cache.h b/cache.h
index 2a206aa..a5272f2 100644
--- a/cache.h
+++ b/cache.h
@@ -471,7 +471,7 @@ extern int add_file_to_index(struct index_state *, const char *path, int flags);
 extern struct cache_entry *make_cache_entry(unsigned int mode, const unsigned char *sha1, const char *path, int stage, int refresh);
 extern int ce_same_name(struct cache_entry *a, struct cache_entry *b);
 extern int index_name_is_other(const struct index_state *, const char *, int);
-extern void *read_blob_data_from_index_path(const char *path, struct index_state *use_index);
+extern void *read_blob_data_from_index_path(const char *path, struct index_state *use_index, unsigned long *size);
 
 /* do stat comparison even if CE_VALID is true */
 #define CE_MATCH_IGNORE_VALID		01
diff --git a/read-cache.c b/read-cache.c
index 964ae26..547e98a 100644
--- a/read-cache.c
+++ b/read-cache.c
@@ -1901,7 +1901,8 @@ int index_name_is_other(const struct index_state *istate, const char *name,
 }
 
 void *read_blob_data_from_index_path(const char *path,
-				     struct index_state *use_index)
+				     struct index_state *use_index,
+				     unsigned long *size)
 {
 	int pos, len;
 	unsigned long sz;
@@ -1931,5 +1932,7 @@ void *read_blob_data_from_index_path(const char *path,
 		free(data);
 		return NULL;
 	}
+	if (size)
+		*size = sz;
 	return data;
 }
-- 
1.8.2.675.gda3bb24.dirty
Previous: Lukas FleischerNext: Lukas Fleischer
Message 8 of 12 in “Remove ~25 lines of duplicate code”
  1. 0/3 Remove ~25 lines of duplicate codeLukas Fleischer, Apr 12, 2013
  2. 1/3 Make read_index_data() publicLukas Fleischer, Apr 12, 2013
  3. Jeff KingApr 12, 2013
  4. Lukas FleischerApr 13, 2013
  5. 2/3 Add size parameter to read_index_data()Lukas Fleischer, Apr 12, 2013
  6. 3/3 convert.c: Remove duplicate codeLukas Fleischer, Apr 12, 2013
  7. 1/3 Add public function read_blob_data_from_index_path()Lukas Fleischer, Apr 13, 2013
  8. 2/3 Add size parameter to read_blob_data_from_index_path()Lukas Fleischer, Apr 13, 2013
  9. 3/3 convert.c: Remove duplicate codeLukas Fleischer, Apr 13, 2013
  10. Junio C HamanoApr 14, 2013
  11. Junio C HamanoApr 14, 2013
  12. Lukas FleischerApr 14, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.