git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v5 18/25] revision.c: allow handle_revision_arg() to take other flags

From
Junio C Hamano <gitster@pobox.com>
Date
Jul 3, 2012, 21:37 UTC
Message-ID
<1341351435-31011-19-git-send-email-gitster@pobox.com>
In-Reply-To
<1341351435-31011-1-git-send-email-gitster@pobox.com>

The existing "cant_be_filename" that tells the function that the caller knows the arg is not a path (hence it does not have to be checked for absense of the file whose name matches it) is made into a bit in the flag word.

Signed-off-by: Junio C Hamano <gitster@pobox.com>
---
 builtin/pack-objects.c |  2 +-
 revision.c             | 13 +++++++------
 revision.h             |  3 ++-
 3 files changed, 10 insertions(+), 8 deletions(-)
diff --git a/builtin/pack-objects.c b/builtin/pack-objects.c
index 0f2e7b8..48ccadd 100644
--- a/builtin/pack-objects.c
+++ b/builtin/pack-objects.c
@@ -2290,7 +2290,7 @@ static void get_object_list(int ac, const char **av)
 			}
 			die("not a rev '%s'", line);
 		}
-		if (handle_revision_arg(line, &revs, flags, 1))
+		if (handle_revision_arg(line, &revs, flags, REVARG_CANNOT_BE_FILENAME))
 			die("bad revision '%s'", line);
 	}
 
diff --git a/revision.c b/revision.c
index c3160f2..929497f 100644
--- a/revision.c
+++ b/revision.c
@@ -1093,9 +1093,7 @@ static void prepare_show_merge(struct rev_info *revs)
 	revs->limited = 1;
 }
 
-int handle_revision_arg(const char *arg_, struct rev_info *revs,
-			int flags,
-			int cant_be_filename)
+int handle_revision_arg(const char *arg_, struct rev_info *revs, int flags, unsigned revarg_opt)
 {
 	struct object_context oc;
 	char *dotdot;
@@ -1103,6 +1101,7 @@ int handle_revision_arg(const char *arg_, struct rev_info *revs,
 	unsigned char sha1[20];
 	int local_flags;
 	const char *arg = arg_;
+	int cant_be_filename = revarg_opt & REVARG_CANNOT_BE_FILENAME;
 
 	dotdot = strstr(arg, "..");
 	if (dotdot) {
@@ -1236,7 +1235,7 @@ static void read_revisions_from_stdin(struct rev_info *revs,
 			}
 			die("options not supported in --stdin mode");
 		}
-		if (handle_revision_arg(sb.buf, revs, 0, 1))
+		if (handle_revision_arg(sb.buf, revs, 0, REVARG_CANNOT_BE_FILENAME))
 			die("bad revision '%s'", sb.buf);
 	}
 	if (seen_dashdash)
@@ -1684,7 +1683,7 @@ static int handle_revision_pseudo_opt(const char *submodule,
  */
 int setup_revisions(int argc, const char **argv, struct rev_info *revs, struct setup_revision_opt *opt)
 {
-	int i, flags, left, seen_dashdash, read_from_stdin, got_rev_arg = 0;
+	int i, flags, left, seen_dashdash, read_from_stdin, got_rev_arg = 0, revarg_opt;
 	struct cmdline_pathspec prune_data;
 	const char *submodule = NULL;
 
@@ -1708,6 +1707,7 @@ int setup_revisions(int argc, const char **argv, struct rev_info *revs, struct s
 
 	/* Second, deal with arguments and options */
 	flags = 0;
+	revarg_opt = seen_dashdash ? REVARG_CANNOT_BE_FILENAME : 0;
 	read_from_stdin = 0;
 	for (left = i = 1; i < argc; i++) {
 		const char *arg = argv[i];
@@ -1743,7 +1743,8 @@ int setup_revisions(int argc, const char **argv, struct rev_info *revs, struct s
 			continue;
 		}
 
-		if (handle_revision_arg(arg, revs, flags, seen_dashdash)) {
+
+		if (handle_revision_arg(arg, revs, flags, revarg_opt)) {
 			int j;
 			if (seen_dashdash || *arg == '^')
 				die("bad revision '%s'", arg);
diff --git a/revision.h b/revision.h
index b8e9223..8eceaec 100644
--- a/revision.h
+++ b/revision.h
@@ -190,7 +190,8 @@ extern int setup_revisions(int argc, const char **argv, struct rev_info *revs, s
 extern void parse_revision_opt(struct rev_info *revs, struct parse_opt_ctx_t *ctx,
 				 const struct option *options,
 				 const char * const usagestr[]);
-extern int handle_revision_arg(const char *arg, struct rev_info *revs,int flags,int cant_be_filename);
+#define REVARG_CANNOT_BE_FILENAME 01
+extern int handle_revision_arg(const char *arg, struct rev_info *revs, int flags, unsigned revarg_opt);
 
 extern int prepare_revision_walk(struct rev_info *revs);
 extern struct commit *get_revision(struct rev_info *revs);
-- 
1.7.11.1.229.g706c98f
Previous: Junio C HamanoNext: Junio C Hamano
Message 19 of 26 in “Extending the shelf-life of "git describe" output”
  1. 00/25 Extending the shelf-life of "git describe" outputJunio C Hamano, Jul 3, 2012
  2. 01/25 sha1_name.c: indentation fixJunio C Hamano, Jul 3, 2012
  3. 02/25 sha1_name.c: hide get_sha1_with_context_1() uglinessJunio C Hamano, Jul 3, 2012
  4. 03/25 sha1_name.c: get rid of get_sha1_with_mode_1()Junio C Hamano, Jul 3, 2012
  5. 04/25 sha1_name.c: get rid of get_sha1_with_mode()Junio C Hamano, Jul 3, 2012
  6. 05/25 sha1_name.c: clarify what "fake" is for in find_short_object_filename()Junio C Hamano, Jul 3, 2012
  7. 06/25 sha1_name.c: rename "now" to "current"Junio C Hamano, Jul 3, 2012
  8. 07/25 sha1_name.c: refactor find_short_packed_object()Junio C Hamano, Jul 3, 2012
  9. 08/25 sha1_name.c: correct misnamed "canonical" and "res"Junio C Hamano, Jul 3, 2012
  10. 09/25 sha1_name.c: restructure disambiguation of short namesJunio C Hamano, Jul 3, 2012
  11. 10/25 get_sha1(): fix error status regressionJunio C Hamano, Jul 3, 2012
  12. 11/25 sha1_name.c: allow get_short_sha1() to take other flagsJunio C Hamano, Jul 3, 2012
  13. 12/25 sha1_name.c: teach get_short_sha1() a commit-only optionJunio C Hamano, Jul 3, 2012
  14. 13/25 sha1_name.c: get_describe_name() by definition groks only commitsJunio C Hamano, Jul 3, 2012
  15. 14/25 sha1_name.c: get_sha1_1() takes lookup flagsJunio C Hamano, Jul 3, 2012
  16. 15/25 sha1_name.c: many short names can only be committishJunio C Hamano, Jul 3, 2012
  17. 16/25 sha1_name.c: teach lookup context to get_sha1_with_context()Junio C Hamano, Jul 3, 2012
  18. 17/25 sha1_name.c: introduce get_sha1_committish()Junio C Hamano, Jul 3, 2012
  19. 18/25 revision.c: allow handle_revision_arg() to take other flagsJunio C Hamano, Jul 3, 2012
  20. 19/25 revision.c: the "log" family, except for "show", takes committishJunio C Hamano, Jul 3, 2012
  21. 20/25 sha1_name.c: add support for disambiguating other typesJunio C Hamano, Jul 3, 2012
  22. 21/25 apply: --build-fake-ancestor expects blobsJunio C Hamano, Jul 3, 2012
  23. 22/25 commit-tree: the command wants a tree and commitsJunio C Hamano, Jul 3, 2012
  24. 23/25 reset: the command takes committishJunio C Hamano, Jul 3, 2012
  25. 24/25 rev-parse: A and B in "rev-parse A..B" refer to committishJunio C Hamano, Jul 3, 2012
  26. 25/25 rev-parse --disambiguate=<prefix>Junio C Hamano, Jul 3, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.