git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v5 11/25] sha1_name.c: allow get_short_sha1() to take other flags

From
Junio C Hamano <gitster@pobox.com>
Date
Jul 3, 2012, 21:37 UTC
Message-ID
<1341351435-31011-12-git-send-email-gitster@pobox.com>
In-Reply-To
<1341351435-31011-1-git-send-email-gitster@pobox.com>

Instead of a separate "int quietly" argument, make it take "unsigned flags" so that we can pass other options to it.

The bit assignment of this flag word is exposed in cache.h because the mechanism will be exposed to callers of the higher layer in later commits in this series.

Signed-off-by: Junio C Hamano <gitster@pobox.com>
---
 cache.h     | 2 ++
 sha1_name.c | 7 ++++---
 2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/cache.h b/cache.h
index 2aa9fb6..1bafa45 100644
--- a/cache.h
+++ b/cache.h
@@ -811,6 +811,8 @@ struct object_context {
 	unsigned mode;
 };
 
+#define GET_SHA1_QUIETLY 01
+
 extern int get_sha1(const char *str, unsigned char *sha1);
 extern void maybe_die_on_misspelt_object_name(const char *name, const char *prefix);
 extern int get_sha1_with_context(const char *str, unsigned char *sha1, struct object_context *orc);
diff --git a/sha1_name.c b/sha1_name.c
index c824bdd..793d80c 100644
--- a/sha1_name.c
+++ b/sha1_name.c
@@ -219,12 +219,13 @@ static int finish_object_disambiguation(struct disambiguate_state *ds,
 }
 
 static int get_short_sha1(const char *name, int len, unsigned char *sha1,
-			  int quietly)
+			  unsigned flags)
 {
 	int i, status;
 	char hex_pfx[40];
 	unsigned char bin_pfx[20];
 	struct disambiguate_state ds;
+	int quietly = !!(flags & GET_SHA1_QUIETLY);
 
 	if (len < MINIMUM_ABBREV || len > 40)
 		return -1;
@@ -272,7 +273,7 @@ const char *find_unique_abbrev(const unsigned char *sha1, int len)
 		return hex;
 	while (len < 40) {
 		unsigned char sha1_ret[20];
-		status = get_short_sha1(hex, len, sha1_ret, 1);
+		status = get_short_sha1(hex, len, sha1_ret, GET_SHA1_QUIETLY);
 		if (exists
 		    ? !status
 		    : status == SHORT_NAME_NOT_FOUND) {
@@ -603,7 +604,7 @@ static int get_describe_name(const char *name, int len, unsigned char *sha1)
 			if (ch == 'g' && cp[-1] == '-') {
 				cp++;
 				len -= cp - name;
-				return get_short_sha1(cp, len, sha1, 1);
+				return get_short_sha1(cp, len, sha1, GET_SHA1_QUIETLY);
 			}
 		}
 	}
-- 
1.7.11.1.229.g706c98f
Previous: Junio C HamanoNext: Junio C Hamano
Message 12 of 26 in “Extending the shelf-life of "git describe" output”
  1. 00/25 Extending the shelf-life of "git describe" outputJunio C Hamano, Jul 3, 2012
  2. 01/25 sha1_name.c: indentation fixJunio C Hamano, Jul 3, 2012
  3. 02/25 sha1_name.c: hide get_sha1_with_context_1() uglinessJunio C Hamano, Jul 3, 2012
  4. 03/25 sha1_name.c: get rid of get_sha1_with_mode_1()Junio C Hamano, Jul 3, 2012
  5. 04/25 sha1_name.c: get rid of get_sha1_with_mode()Junio C Hamano, Jul 3, 2012
  6. 05/25 sha1_name.c: clarify what "fake" is for in find_short_object_filename()Junio C Hamano, Jul 3, 2012
  7. 06/25 sha1_name.c: rename "now" to "current"Junio C Hamano, Jul 3, 2012
  8. 07/25 sha1_name.c: refactor find_short_packed_object()Junio C Hamano, Jul 3, 2012
  9. 08/25 sha1_name.c: correct misnamed "canonical" and "res"Junio C Hamano, Jul 3, 2012
  10. 09/25 sha1_name.c: restructure disambiguation of short namesJunio C Hamano, Jul 3, 2012
  11. 10/25 get_sha1(): fix error status regressionJunio C Hamano, Jul 3, 2012
  12. 11/25 sha1_name.c: allow get_short_sha1() to take other flagsJunio C Hamano, Jul 3, 2012
  13. 12/25 sha1_name.c: teach get_short_sha1() a commit-only optionJunio C Hamano, Jul 3, 2012
  14. 13/25 sha1_name.c: get_describe_name() by definition groks only commitsJunio C Hamano, Jul 3, 2012
  15. 14/25 sha1_name.c: get_sha1_1() takes lookup flagsJunio C Hamano, Jul 3, 2012
  16. 15/25 sha1_name.c: many short names can only be committishJunio C Hamano, Jul 3, 2012
  17. 16/25 sha1_name.c: teach lookup context to get_sha1_with_context()Junio C Hamano, Jul 3, 2012
  18. 17/25 sha1_name.c: introduce get_sha1_committish()Junio C Hamano, Jul 3, 2012
  19. 18/25 revision.c: allow handle_revision_arg() to take other flagsJunio C Hamano, Jul 3, 2012
  20. 19/25 revision.c: the "log" family, except for "show", takes committishJunio C Hamano, Jul 3, 2012
  21. 20/25 sha1_name.c: add support for disambiguating other typesJunio C Hamano, Jul 3, 2012
  22. 21/25 apply: --build-fake-ancestor expects blobsJunio C Hamano, Jul 3, 2012
  23. 22/25 commit-tree: the command wants a tree and commitsJunio C Hamano, Jul 3, 2012
  24. 23/25 reset: the command takes committishJunio C Hamano, Jul 3, 2012
  25. 24/25 rev-parse: A and B in "rev-parse A..B" refer to committishJunio C Hamano, Jul 3, 2012
  26. 25/25 rev-parse --disambiguate=<prefix>Junio C Hamano, Jul 3, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.