git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v3 0/9] Extending the shelf-life of "git describe" output

From
Junio C Hamano <gitster@pobox.com>
Date
Jun 24, 2012, 00:11 UTC
Message-ID
<1340496691-12258-1-git-send-email-gitster@pobox.com>
This is take 3.  The earlier rounds were $gmane/200165 and 200387.

Only the [9/9] is different. It adds a test that creates a history with many objects whose names share the same prefix, and tries to check how the implementation employs various possible disambiguations, e.g.

 (1) "$tagname-$generation-g$shortname" can only name a commit
     object, which is the topic of this series;
 (2) "$shortname" in "$tagname-$generation-g$shortname" alone may
     not be sufficiently unambiguous to name a commit, but there may
     be only one such commit if we take $tagname and $generation
     into account, which I hinted as a possible enhancement in the
     cover letter of the first round of this series;
 (3) "$shortname" in "$shortname:$path" can only name a tree-ish,
     which Thomas volunteered to build on top of this series;
 (4) "$shortname" in "$shortname^0" and "$shortname^{commit}" can
     only name a commit-ish, which is a natural extension of (3);
 (5) "$shortname" in "$shortname^0" and "$shortname^{commit}" might
     name more than one commit-ish, but when they are peeled to
     commits, they may name the same one (e.g. one is the commit,
     the other is a tag to the commit), which is a natural extension
     of (4).

Currently, the code implements only (1) and all other tests are marked as test_expect_failure.

Junio C Hamano (9):
  sha1_name.c: indentation fix
  sha1_name.c: clarify what "fake" is for in
    find_short_object_filename()
  sha1_name.c: rename "now" to "current"
  sha1_name.c: refactor find_short_packed_object()
  sha1_name.c: correct misnamed "canonical" and "res"
  sha1_name.c: restructure disambiguation of short names
  sha1_name.c: allow get_short_sha1() to take other flags
  sha1_name.c: teach get_short_sha1() a commit-only option
  sha1_name.c: get_describe_name() by definition groks only commits
 sha1_name.c                         | 282 +++++++++++++++++++++++-------------
 t/t1512-rev-parse-disambiguation.sh | 172 ++++++++++++++++++++++
 2 files changed, 354 insertions(+), 100 deletions(-)
 create mode 100755 t/t1512-rev-parse-disambiguation.sh
-- 
1.7.11.1.29.gf71be5c
Next: Junio C Hamano
Message 1 of 11 in “Extending the shelf-life of "git describe" output”
  1. 0/9 Extending the shelf-life of "git describe" outputJunio C Hamano, Jun 24, 2012
  2. 1/9 sha1_name.c: indentation fixJunio C Hamano, Jun 24, 2012
  3. 2/9 sha1_name.c: clarify what "fake" is for in find_short_object_filename()Junio C Hamano, Jun 24, 2012
  4. 3/9 sha1_name.c: rename "now" to "current"Junio C Hamano, Jun 24, 2012
  5. 4/9 sha1_name.c: refactor find_short_packed_object()Junio C Hamano, Jun 24, 2012
  6. 5/9 sha1_name.c: correct misnamed "canonical" and "res"Junio C Hamano, Jun 24, 2012
  7. 6/9 sha1_name.c: restructure disambiguation of short namesJunio C Hamano, Jun 24, 2012
  8. 7/9 sha1_name.c: allow get_short_sha1() to take other flagsJunio C Hamano, Jun 24, 2012
  9. 8/9 sha1_name.c: teach get_short_sha1() a commit-only optionJunio C Hamano, Jun 24, 2012
  10. 9/9 sha1_name.c: get_describe_name() by definition groks only commitsJunio C Hamano, Jun 24, 2012
  11. Junio C HamanoJun 24, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.