git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 09/18] revert: Separate cmdline parsing from functional code

From
Ramkumar Ramachandra <artagnon@gmail.com>
Date
Jul 19, 2011, 17:17 UTC
Message-ID
<1311095876-3098-10-git-send-email-artagnon@gmail.com>
In-Reply-To
<1311095876-3098-1-git-send-email-artagnon@gmail.com>

Currently, revert_or_cherry_pick sets up a default git config, parses command-line arguments, before preparing to pick commits. This makes for a bad API as the central worry of callers is to assert whether or not a conflict occured while cherry picking. The current API is like:

if (revert_or_cherry_pick(argc, argv, opts) < 0)
   print "Something failed, we're not sure what"

Simplify and rename revert_or_cherry_pick to pick_commits so that it only has the responsibility of setting up the revision walker and picking commits in a loop. Transfer the remaining work to its callers. Now, the API is simplified as:

if (parse_args(argc, argv, opts) < 0)
   print "Can't parse arguments"
if (pick_commits(opts) < 0)
   print "Error encountered in picking machinery"

Later in the series, pick_commits will also serve as the starting point for continuing a cherry-pick or revert.

Inspired-by: Christian Couder <chriscool@tuxfamily.org>
Helped-by: Jonathan Nieder <jrnieder@gmail.com>
Signed-off-by: Ramkumar Ramachandra <artagnon@gmail.com>
---
 builtin/revert.c |   14 +++++++-------
 1 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/builtin/revert.c b/builtin/revert.c
index c118fd3..047b0aa 100644
--- a/builtin/revert.c
+++ b/builtin/revert.c
@@ -558,16 +558,12 @@ static void read_and_refresh_cache(struct replay_opts *opts)
 	rollback_lock_file(&index_lock);
 }
 
-static int revert_or_cherry_pick(int argc, const char **argv,
-				struct replay_opts *opts)
+static int pick_commits(struct replay_opts *opts)
 {
 	struct rev_info revs;
 	struct commit *commit;
 
-	git_config(git_default_config, NULL);
 	setenv(GIT_REFLOG_ACTION, action_name(opts), 0);
-	parse_args(argc, argv, opts);
-
 	if (opts->allow_ff) {
 		if (opts->signoff)
 			die(_("cherry-pick --ff cannot be used with --signoff"));
@@ -601,7 +597,9 @@ int cmd_revert(int argc, const char **argv, const char *prefix)
 	if (isatty(0))
 		opts.edit = 1;
 	opts.action = REVERT;
-	res = revert_or_cherry_pick(argc, argv, &opts);
+	git_config(git_default_config, NULL);
+	parse_args(argc, argv, &opts);
+	res = pick_commits(&opts);
 	if (res < 0)
 		die(_("revert failed"));
 	return res;
@@ -614,7 +612,9 @@ int cmd_cherry_pick(int argc, const char **argv, const char *prefix)
 
 	memset(&opts, 0, sizeof(struct replay_opts));
 	opts.action = CHERRY_PICK;
-	res = revert_or_cherry_pick(argc, argv, &opts);
+	git_config(git_default_config, NULL);
+	parse_args(argc, argv, &opts);
+	res = pick_commits(&opts);
 	if (res < 0)
 		die(_("cherry-pick failed"));
 	return res;
-- 
1.7.4.rc1.7.g2cf08.dirty
Previous: Ramkumar RamachandraNext: Ramkumar Ramachandra
Message 20 of 34 in “[GSoC update] Sequencer for inclusion v2”
  1. Ramkumar RamachandraJul 19, 2011
  2. 01/18 advice: Introduce error_resolve_conflictRamkumar Ramachandra, Jul 19, 2011
  3. Phil HordJul 21, 2011
  4. Jeff KingJul 22, 2011
  5. Ramkumar RamachandraJul 24, 2011
  6. Junio C HamanoJul 24, 2011
  7. Phil HordJul 25, 2011
  8. 02/18 config: Introduce functions to write non-standard fileRamkumar Ramachandra, Jul 19, 2011
  9. Jeff KingJul 19, 2011
  10. Jonathan NiederJul 19, 2011
  11. Junio C HamanoJul 19, 2011
  12. Jeff KingJul 19, 2011
  13. Ramkumar RamachandraJul 24, 2011
  14. 03/18 revert: Simplify and inline add_message_to_msgRamkumar Ramachandra, Jul 19, 2011
  15. 04/18 revert: Don't check lone argument in get_encodingRamkumar Ramachandra, Jul 19, 2011
  16. 05/18 revert: Rename no_replay to record_originRamkumar Ramachandra, Jul 19, 2011
  17. 06/18 revert: Propogate errors upwards from do_pick_commitRamkumar Ramachandra, Jul 19, 2011
  18. 07/18 revert: Eliminate global "commit" variableRamkumar Ramachandra, Jul 19, 2011
  19. 08/18 revert: Introduce struct to keep command-line optionsRamkumar Ramachandra, Jul 19, 2011
  20. 09/18 revert: Separate cmdline parsing from functional codeRamkumar Ramachandra, Jul 19, 2011
  21. 10/18 revert: Don't create invalid replay_opts in parse_argsRamkumar Ramachandra, Jul 19, 2011
  22. 11/18 revert: Save data for continuing after conflict resolutionRamkumar Ramachandra, Jul 19, 2011
  23. 12/18 revert: Save command-line options for continuing operationRamkumar Ramachandra, Jul 19, 2011
  24. 13/18 revert: Make pick_commits functionally act on a commit listRamkumar Ramachandra, Jul 19, 2011
  25. 14/18 revert: Introduce --reset to remove sequencer stateRamkumar Ramachandra, Jul 19, 2011
  26. 15/18 reset: Make reset remove the sequencer stateRamkumar Ramachandra, Jul 19, 2011
  27. 16/18 revert: Remove sequencer state when no commits are pendingRamkumar Ramachandra, Jul 19, 2011
  28. 17/18 revert: Don't implictly stomp pending sequencer operationRamkumar Ramachandra, Jul 19, 2011
  29. 18/18 revert: Introduce --continue to continue the operationRamkumar Ramachandra, Jul 19, 2011
  30. Junio C HamanoJul 19, 2011
  31. Ramkumar RamachandraJul 20, 2011
  32. Junio C HamanoJul 19, 2011
  33. Ramkumar RamachandraJul 24, 2011
  34. Junio C HamanoJul 24, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.