[PATCH v4 00/10] Sequencer Foundations
- From
Ramkumar Ramachandra <artagnon@gmail.com>
- Date
- May 26, 2011, 15:53 UTC
- Message-ID
- <1306425233-504-1-git-send-email-artagnon@gmail.com>
- In-Reply-To
- <1306333025-29893-1-git-send-email-artagnon@gmail.com>
Hi,
This is a quick re-roll after Junio's review of the previous iteration; the previous iteration was posted less than 24 hours ago. I'm in a hurry, because I want to make sure that this is ready (or nearly ready) for merge before I actually implement more features.
Thanks for reading.
Ramkumar Ramachandra (10): advice: Introduce error_resolve_conflict revert: Propogate errors upwards from do_pick_commit revert: Eliminate global "commit" variable revert: Rename no_replay to record_origin revert: Introduce struct to keep command-line options revert: Separate cmdline parsing from functional code revert: Catch incompatible command-line options early revert: Introduce HEAD, TODO files to persist state, plan revert: Implement parsing --continue, --abort and --skip revert: Implement --abort processing
advice.c | 17 ++- advice.h | 1 + builtin/revert.c | 492 ++++++++++++++++++++++++++++++++++++++---------------- 3 files changed, 360 insertions(+), 150 deletions(-)
-- 1.7.5.GIT