Re: [PATCH] sequencer: allow disabling conflict advice
- From
Philippe Blain <levraiphilippeblain@gmail.com>
- Date
- Mar 9, 2024, 17:53 UTC
- Message-ID
- <12c84208-23a7-5ba7-18a9-822d9a8f66fa@gmail.com>
- In-Reply-To
- <xmqqy1axq3t1.fsf@gitster.g>
Hi Phillip and Junio,
Le 2024-03-04 à 12:56, Junio C Hamano a écrit :
Show 8 quoted lines
> Phillip Wood <phillip.wood123@gmail.com> writes: > >> ... So we probably do need a new config variable but >> I think it should have a generic name - not be sequencer specific so >> we can extend its scope in the future to "git merge", "git am -3", >> "git stash" etc. > > A very good point. Thanks for your careful thinking.
OK, I agree we can make the new advice more generic, but I'm lacking inspiration for the name. Maybe 'advice.mergeConflicted' ? Or 'advice.resolveConflictedMerge' ? though this is close to the existing 'resolveConflict'... Maybe just 'advice.mergeConflict' ?
Thanks, Philippe.