[RFC/PATCH 0/3] gitweb: Refactor common parts of log-like views
- From
Jakub Narebski <jnareb@gmail.com>
- Date
- Nov 13, 2009, 01:02 UTC
- Message-ID
- <1258074134-27011-1-git-send-email-jnareb@gmail.com>
This series extracts common parts of log-like views: 'log', 'shortlog' and 'history' view, into git_log_generic() subroutine. This unification of code reduces code duplication, and brings features such as limiting the list of commits displayed using $hash_parent{,_base} from 'shortlog' view (added in ec3e97b (gitweb: shortlog now also obeys $hash_parent, 2008-08-08)).
I have tested this series a bit (it passes both t9500 and t9501 test), but I didn't test all the corner cases.
This series is preparation for even more refactoring planned, to make it easier to introduce new log-like action (new log formats). It doesn't include (for now) the 'search' view, neither in message search not in pickaxe search form.
Jakub Narebski (3): gitweb: Refactor 'log' action generation, adding git_log_body() gitweb: Refactor common parts of 'log' and 'shortlog' views gitweb: Make 'history' view (re)use git_log_generic()
gitweb/gitweb.perl | 269 +++++++++++++++++++++------------------------------- 1 files changed, 110 insertions(+), 159 deletions(-)
-- Jakub Narebski