[JGIT PATCH 05/12] Rename Config.unsetString to just unset()
- From
Shawn O. Pearce <spearce@spearce.org>
- Date
- Jul 21, 2009, 20:19 UTC
- Message-ID
- <1248207570-13880-6-git-send-email-spearce@spearce.org>
- In-Reply-To
- <1248207570-13880-5-git-send-email-spearce@spearce.org>
Removing a configuration option means deleting it from the file, implying a value type during the deletion makes no sense.
Signed-off-by: Shawn O. Pearce <spearce@spearce.org> --- .../src/org/spearce/jgit/lib/Config.java | 2 +- .../org/spearce/jgit/transport/RemoteConfig.java | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/org.spearce.jgit/src/org/spearce/jgit/lib/Config.java b/org.spearce.jgit/src/org/spearce/jgit/lib/Config.java index 20f42c4..4a60199 100644 --- a/org.spearce.jgit/src/org/spearce/jgit/lib/Config.java +++ b/org.spearce.jgit/src/org/spearce/jgit/lib/Config.java @@ -547,7 +547,7 @@ public void setString(final String section, final String subsection, * @param name * parameter name, e.g. "filemode" */ - public void unsetString(final String section, final String subsection, + public void unset(final String section, final String subsection, final String name) { setStringList(section, subsection, name, Collections .<String> emptyList()); diff --git a/org.spearce.jgit/src/org/spearce/jgit/transport/RemoteConfig.java b/org.spearce.jgit/src/org/spearce/jgit/transport/RemoteConfig.java index fac04f6..93a5873 100644 --- a/org.spearce.jgit/src/org/spearce/jgit/transport/RemoteConfig.java +++ b/org.spearce.jgit/src/org/spearce/jgit/transport/RemoteConfig.java @@ -247,7 +247,7 @@ private void set(final RepositoryConfig rc, final String key, } private void unset(final RepositoryConfig rc, final String key) { - rc.unsetString(SECTION, getName(), key); + rc.unset(SECTION, getName(), key); } /**
-- 1.6.4.rc1.186.g60aa0c