git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[JGIT PATCH 02/12] Correct name of fileRead member of Config class

From
Shawn O. Pearce <spearce@spearce.org>
Date
Jul 21, 2009, 20:19 UTC
Message-ID
<1248207570-13880-3-git-send-email-spearce@spearce.org>
In-Reply-To
<1248207570-13880-2-git-send-email-spearce@spearce.org>

The setter method is called setFileRead() so the member should have been called fileRead, not readFile.

Signed-off-by: Shawn O. Pearce <spearce@spearce.org>
---
 .../src/org/spearce/jgit/lib/Config.java           |    9 ++++-----
 1 files changed, 4 insertions(+), 5 deletions(-)
diff --git a/org.spearce.jgit/src/org/spearce/jgit/lib/Config.java b/org.spearce.jgit/src/org/spearce/jgit/lib/Config.java
index c2d5c6e..a31796c 100644
--- a/org.spearce.jgit/src/org/spearce/jgit/lib/Config.java
+++ b/org.spearce.jgit/src/org/spearce/jgit/lib/Config.java
@@ -60,8 +60,7 @@
  * file.
  */
 public abstract class Config {
-
-	private boolean readFile;
+	private boolean fileRead;
 
 	private List<Entry> entries;
 
@@ -96,7 +95,7 @@ protected Config(Config base) {
 	 *            true if file does not need loading
 	 */
 	protected void setFileRead(boolean ok) {
-		readFile = ok;
+		fileRead = ok;
 	}
 
 	/**
@@ -404,7 +403,7 @@ private String getRawString(final String section, final String subsection,
 	}
 
 	private void ensureLoaded() {
-		if (!readFile) {
+		if (!fileRead) {
 			try {
 				load();
 			} catch (FileNotFoundException err) {
@@ -703,7 +702,7 @@ protected void printConfig(final PrintWriter r) {
 	 */
 	public void load() throws IOException {
 		clear();
-		readFile = true;
+		fileRead = true;
 		final BufferedReader r = new BufferedReader(new InputStreamReader(
 				openInputStream(), Constants.CHARSET));
 		try {
-- 
1.6.4.rc1.186.g60aa0c
Previous: Shawn O. PearceNext: Shawn O. Pearce
Message 3 of 18 in “Cleanup Config class”
  1. 00/12 Cleanup Config classShawn O. Pearce, Jul 21, 2009
  2. 01/12 Use NB.readFully(File) to slurp complete file contentsShawn O. Pearce, Jul 21, 2009
  3. 02/12 Correct name of fileRead member of Config classShawn O. Pearce, Jul 21, 2009
  4. 03/12 Add setLong to ConfigShawn O. Pearce, Jul 21, 2009
  5. 04/12 Fix Config setInt(..., 0) to store "0" not "0 g"Shawn O. Pearce, Jul 21, 2009
  6. 05/12 Rename Config.unsetString to just unset()Shawn O. Pearce, Jul 21, 2009
  7. 06/12 Remove pointless null assignments in ConfigShawn O. Pearce, Jul 21, 2009
  8. 07/12 Clarify section and subsection values in Config codeShawn O. Pearce, Jul 21, 2009
  9. 08/12 Don't subclass PrintWriter when writing the ConfigShawn O. Pearce, Jul 21, 2009
  10. 09/12 Use a Java 5 style iteration over the Config entries listShawn O. Pearce, Jul 21, 2009
  11. 10/12 Match config subsection names using case sensitive searchShawn O. Pearce, Jul 21, 2009
  12. 11/12 Cleanup Config's MAGIC_EMPTY_VALUE to be more safeShawn O. Pearce, Jul 21, 2009
  13. 12/12 Remove unreferenced REMOTE_SECTION from RepositoryConfigShawn O. Pearce, Jul 21, 2009
  14. Robin RosenbergJul 21, 2009
  15. Shawn O. PearceJul 21, 2009
  16. Constantine PlotnikovJul 22, 2009
  17. Robin RosenbergJul 22, 2009
  18. Ensure Config readers handle case insensitive names correctlyShawn O. Pearce, Jul 24, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.