Michael Haggerty
@mhagger on GitHub. Posts as mhagger@alum.mit.edu.
4,191
messages
2,397
patches posted
83%
of 127 series merged
269
threads started
2006
first message, Sep 14, 2006
Nov 16, 2018
since the latest message
Patch series
Of 127 patch series (re-rolls counted once), 105 landed on master and 22 did not.
- mergedSupplements to "packed_ref_cache: don't use mmap() for small files"Jan 24, 2018, 4a2854f77c
- mergedTidy up the constants related to ref_update::flagsv2, Nov 5, 2017, b00f3cfa92
- mergedAvoid rewriting "packed-refs" unnecessarilyv2, Oct 28, 2017, 7c6bd25c7d
- mergedt0000: check whether the shell supports the "local" keywordOct 26, 2017, 01d3a526ad
- mergedFix an error-handling path when locking refsOct 24, 2017, 2e9de01aa0
- mergedRead `packed-refs` using mmap()v3, Sep 25, 2017, 8738a8a4df
- not mergedfor_each_string_list_item(): behave correctly for empty listSep 15, 2017
- mergedload_subtree(): check that `prefix_len` is in the expected rangeSep 8, 2017, 3964281524
- mergedImplement transactions for the packed ref storev2, Sep 8, 2017, 27d03d04d5
- mergedClean up notes-related code around `load_subtree()`Aug 26, 2017, 65eb8e0ca7
- not mergedRetry acquiring reference locks for 100msAug 21, 2017
- mergedfiles-backend: cheapen refname_available check when locking refsAug 17, 2017, 8ec617c80c
A series is merged when one of its patches matches a commit on master by the same author, by subject. Versions are linked when they share a patch subject. Patches reworded before landing, or applied under someone else's name, count as not merged.
Recent emails
- Re: [RFC/PATCH 0/5] stop installing old libexec aliases like "git-init"
- Re: [PATCH 00/17] object_id part 14
- Re: [PATCH] xdiff: reduce indent heuristic overhead
- Re: [PATCH] xdiff: reduce indent heuristic overhead
- Re: [PATCH] t9104: kosherly remove remote refs
- Re: [PATCH 1/3] refs/packed-backend.c: close fd of empty file
- Re: [PATCH] t990X: use '.git/objects' as 'deep inside .git' path
- Re: [PATCH v2] t: make many tests depend less on the refs being files
- Re: [PATCH v2] t: make many tests depend less on the refs being files
- Re: commit-graph: change in "best" merge-base when ambiguous
- Re: commit-graph: change in "best" merge-base when ambiguous
- Re: Implementing reftable in Git
- Re: [PATCH] refs: handle null-oid for pseudorefs
- Re: [PATCH 12/16] refs: store the main ref store inside the repository struct
- Re: [PATCH 07/16] refs: add repository argument to get_main_ref_store
- [RFC 1/1] packed-backend: ignore broken headers
- [RFC 0/1] Tolerate broken headers in `packed-refs` files
- Re: [ANNOUNCE] git-sizer: compute various size-related metrics for your Git repository
- [ANNOUNCE] git-sizer: compute various size-related metrics for your Git repository
- Re: [git-sizer] Implications of a large commit object
- Re: [PATCH] sq_dequote: fix extra consumption of source string
- Re: make git diff output easier to read - use better diff heuristics
- packed_ref_cache: don't use mmap() for small files
- packed_ref_iterator_begin(): make optimization more general
- load_contents(): don't try to mmap an empty file
- create_snapshot(): use `xmemdupz()` rather than a strbuf
- find_reference_location(): make function safe for empty snapshots
- struct snapshot: store `start` rather than `header_len`
- Yet another approach to handling empty snapshots
- Re: [PATCH v3] packed_ref_cache: don't use mmap() for small files