Ezekiel Newren
@ezekielnewren on GitHub. Posts as ezekielnewren@gmail.com.
416
messages
262
patches posted
100%
of 3 series merged
7
threads started
2025
first message, Jul 17, 2025
Apr 30, 2026
since the latest message
Patch series
Of 3 patch series (re-rolls counted once), 3 landed on master and 0 did not.
- mergedXdiff cleanup part 3v6, Apr 29, 2026, b7b8449e5a
- mergedRFC: Convert to Cargo workspacev6, Nov 27, 2025, efaf553b1a
- mergedMakefile update libgit.a: Include xdiff and reftable in libgit.av2, Oct 2, 2025, cf680cdb95
A series is merged when one of its patches matches a commit on master by the same author, by subject. Versions are linked when they share a patch subject. Patches reworded before landing, or applied under someone else's name, count as not merged.
Recent emails
- Re: [PATCH v6 0/6] Xdiff cleanup part 3
- xdiff/xdl_cleanup_records: make execution of action easier to follow
- xdiff/xdl_cleanup_records: make setting action easier to follow
- xdiff/xdl_cleanup_records: make limits more clear
- xdiff/xdl_cleanup_records: use unambiguous types
- xdiff: use unambiguous types in xdl_bogo_sqrt()
- xdiff/xdl_cleanup_records: delete local recs pointer
- Xdiff cleanup part 3
- Re: [PATCH v4 4/6] xdiff/xdl_cleanup_records: make limits more clear
- xdiff/xdl_cleanup_records: put braces around the else clause
- xdiff/xdl_cleanup_records: make setting action easier to follow
- xdiff/xdl_cleanup_records: make limits more clear
- xdiff/xdl_cleanup_records: use unambiguous types
- xdiff: use unambiguous types in xdl_bogo_sqrt()
- xdiff/xdl_cleanup_records: delete local recs pointer
- Xdiff cleanup part 3
- Re: [PATCH v3 4/6] xdiff/xdl_cleanup_records: make limits more clear
- Re: [PATCH v4 1/6] xdiff/xdl_cleanup_records: delete local recs pointer
- xdiff/xdl_cleanup_records: simplify INVESTIGATE handling for clarity
- xdiff/xdl_cleanup_records: make setting action easier to follow
- xdiff/xdl_cleanup_records: make limits more clear
- xdiff/xdl_cleanup_records: use unambiguous types
- xdiff: use unambiguous types in xdl_bogo_sqrt()
- xdiff/xdl_cleanup_records: delete local recs pointer
- Xdiff cleanup part 3
- Re: [PATCH v3 4/6] xdiff/xdl_cleanup_records: make limits more clear
- xdiff/xdl_cleanup_records: simplify INVESTIGATE handling for clarity
- xdiff/xdl_cleanup_records: make setting action easier to follow
- xdiff/xdl_cleanup_records: make limits more clear
- xdiff/xdl_cleanup_records: use unambiguous types