threads / patch / 40908

patchMake error message after failing commit_lock_file() less confusing

Subject: [PATCH] Make error message after failing commit_lock_file() less confusing

## tl;dr

8 messages between Nov 30, 2015 and Dec 16, 2015. Diffs are folded; open one to read it.

replies: 7people: 4as markdown or json

SZEDER Gábor· Nov 30, 2015, 11:40 UTC · lore

The error message after a failing commit_lock_file() call sometimes looks like this, causing confusion:

  $ git remote add remote git@server.com/repo.git
  error: could not commit config file .git/config
  # Huh?!
  # I didn't want to commit anything, especially not my config file!

While in the narrow context of the lockfile module using the verb 'commit' in the error message makes perfect sense, in the broader context of git the word 'commit' already has a very specific meaning, hence the confusion.

Reword these error messages to say "could not write" instead of "could not commit".

While at it, include strerror in the error messages after writing the config file or the credential store fails to provide some information about the cause of the failure, and update the style of the error message after writing the reflog fails to match surrounding error messages (i.e. no '' around the pathname and no () around the error description).

Signed-off-by: SZEDER Gábor <szeder@ira.uka.de>
---

The error message is of course bikeshedable. Some callers of commit_lock_file() say something like "could not move updated whatever file <path> into place: <strerror>" on error. While it's truer to the meaning of the original error message and conveys more exactly what went wrong (i.e. the actual writing had already finished at that point, it's the move that failed), I think those details are not necessary and the short and simple "could not write" is better.

 config.c           | 6 ++++--
 credential-store.c | 3 ++-
 fast-import.c      | 2 +-
 refs.c             | 2 +-
 4 files changed, 8 insertions(+), 5 deletions(-)
Show changes to 4 files +8 −5

config.c, credential-store.c, fast-import.c, refs.c

diff --git a/config.c b/config.c
index 248a21ab94..86a5eb2571 100644
--- a/config.c
+++ b/config.c
@@ -2144,7 +2144,8 @@ int git_config_set_multivar_in_file(const char *config_filename,
 	}
 
 	if (commit_lock_file(lock) < 0) {
-		error("could not commit config file %s", config_filename);
+		error("could not write config file %s: %s", config_filename,
+		      strerror(errno));
 		ret = CONFIG_NO_WRITE;
 		lock = NULL;
 		goto out_free;
@@ -2330,7 +2331,8 @@ int git_config_rename_section_in_file(const char *config_filename,
 	fclose(config_file);
 unlock_and_out:
 	if (commit_lock_file(lock) < 0)
-		ret = error("could not commit config file %s", config_filename);
+		ret = error("could not write config file %s: %s",
+			    config_filename, strerror(errno));
 out:
 	free(filename_buf);
 	return ret;
diff --git a/credential-store.c b/credential-store.c
index 00aea3aa30..fc67d16c10 100644
--- a/credential-store.c
+++ b/credential-store.c
@@ -64,7 +64,8 @@ static void rewrite_credential_file(const char *fn, struct credential *c,
 		print_line(extra);
 	parse_credential_file(fn, c, NULL, print_line);
 	if (commit_lock_file(&credential_lock) < 0)
-		die_errno("unable to commit credential store");
+		die_errno("unable to write credential store: %s",
+			  strerror(errno));
 }
 
 static void store_credential_file(const char *fn, struct credential *c)
diff --git a/fast-import.c b/fast-import.c
index e3b421d514..3c65edb5c4 100644
--- a/fast-import.c
+++ b/fast-import.c
@@ -1824,7 +1824,7 @@ static void dump_marks(void)
 
 	dump_marks_helper(f, 0, marks);
 	if (commit_lock_file(&mark_lock)) {
-		failure |= error("Unable to commit marks file %s: %s",
+		failure |= error("Unable to write file %s: %s",
 			export_marks_file, strerror(errno));
 		return;
 	}
diff --git a/refs.c b/refs.c
index 132eff52ca..b1c7b229b7 100644
--- a/refs.c
+++ b/refs.c
@@ -4684,7 +4684,7 @@ int reflog_expire(const char *refname, const unsigned char *sha1,
 					get_lock_file_path(lock->lk));
 			rollback_lock_file(&reflog_lock);
 		} else if (commit_lock_file(&reflog_lock)) {
-			status |= error("unable to commit reflog '%s' (%s)",
+			status |= error("unable to write reflog %s: %s",
 					log_file, strerror(errno));
 		} else if (update && commit_ref(lock)) {
 			status |= error("couldn't set %s", lock->ref_name);
-- 
2.6.3.420.g7bbb372
Jeff King· Dec 1, 2015, 23:17 UTC · re: SZEDER Gábor · lore

Re: [PATCH] Make error message after failing commit_lock_file() less confusing

On Mon, Nov 30, 2015 at 12:40:53PM +0100, SZEDER Gábor wrote:
Show 7 quoted lines
> The error message after a failing commit_lock_file() call sometimes
> looks like this, causing confusion:
> 
>   $ git remote add remote git@server.com/repo.git
>   error: could not commit config file .git/config
>   # Huh?!
>   # I didn't want to commit anything, especially not my config file!
I like the intent of this patch; I've had the same "huh" moment myself.
> The error message is of course bikeshedable.

You chose "write", which I think is OK. It's really a "rename", and maybe that matters for some values of errno. I'd guess in practice probably not (the likely reason is going to be something like EPERM). And I can't think of a concise way to express rename (just saying "rename" is confusing, too, without indicating that it's from the tempfile to the final resting place).

So perhaps "write" is the best we can do.
-Peff
Junio C Hamano· Dec 2, 2015, 02:19 UTC · re: Jeff King · lore

Re: [PATCH] Make error message after failing commit_lock_file() less confusing

Jeff King <peff@peff.net> writes:
Show 22 quoted lines
> On Mon, Nov 30, 2015 at 12:40:53PM +0100, SZEDER Gábor wrote:
>
>> The error message after a failing commit_lock_file() call sometimes
>> looks like this, causing confusion:
>> 
>>   $ git remote add remote git@server.com/repo.git
>>   error: could not commit config file .git/config
>>   # Huh?!
>>   # I didn't want to commit anything, especially not my config file!
>
> I like the intent of this patch; I've had the same "huh" moment myself.
>
>> The error message is of course bikeshedable.
>
> You chose "write", which I think is OK. It's really a "rename", and
> maybe that matters for some values of errno. I'd guess in practice
> probably not (the likely reason is going to be something like EPERM).
> And I can't think of a concise way to express rename (just saying
> "rename" is confusing, too, without indicating that it's from the
> tempfile to the final resting place).
>
> So perhaps "write" is the best we can do.

Yeah, "finalize" came to me but "write" is far easier to understand by laypeople.

Eric Sunshine· Dec 2, 2015, 04:28 UTC · re: SZEDER Gábor · lore

Re: [PATCH] Make error message after failing commit_lock_file() less confusing

On Mon, Nov 30, 2015 at 6:40 AM, SZEDER Gábor <szeder@ira.uka.de> wrote:
Show 33 quoted lines
> The error message after a failing commit_lock_file() call sometimes
> looks like this, causing confusion:
>
>   $ git remote add remote git@server.com/repo.git
>   error: could not commit config file .git/config
>   # Huh?!
>   # I didn't want to commit anything, especially not my config file!
>
> While in the narrow context of the lockfile module using the verb
> 'commit' in the error message makes perfect sense, in the broader
> context of git the word 'commit' already has a very specific meaning,
> hence the confusion.
>
> Reword these error messages to say "could not write" instead of "could
> not commit".
>
> While at it, include strerror in the error messages after writing the
> config file or the credential store fails to provide some information
> about the cause of the failure, and update the style of the error
> message after writing the reflog fails to match surrounding error
> messages (i.e. no '' around the pathname and no () around the error
> description).
>
> Signed-off-by: SZEDER Gábor <szeder@ira.uka.de>
> ---
> diff --git a/config.c b/config.c
> @@ -64,7 +64,8 @@ static void rewrite_credential_file(const char *fn, struct credential *c,
>                 print_line(extra);
>         parse_credential_file(fn, c, NULL, print_line);
>         if (commit_lock_file(&credential_lock) < 0)
> -               die_errno("unable to commit credential store");
> +               die_errno("unable to write credential store: %s",
> +                         strerror(errno));

Hmm, this is already calling die_errno(), so adding another strerror() to the mix seems superfluous.

Show 11 quoted lines
>  }
>
>  static void store_credential_file(const char *fn, struct credential *c)
> diff --git a/fast-import.c b/fast-import.c
> @@ -1824,7 +1824,7 @@ static void dump_marks(void)
>
>         dump_marks_helper(f, 0, marks);
>         if (commit_lock_file(&mark_lock)) {
> -               failure |= error("Unable to commit marks file %s: %s",
> +               failure |= error("Unable to write file %s: %s",
>                         export_marks_file, strerror(errno));

Since you're already doing some normalization of the error messages with this patch, do you want to drop capitalization on this one?

>                 return;
>         }
SZEDER Gábor· Dec 3, 2015, 10:30 UTC · re: Eric Sunshine · lore

Re: [PATCH] Make error message after failing commit_lock_file() less confusing

Quoting Eric Sunshine <sunshine@sunshineco.com>:
Show 12 quoted lines
>> diff --git a/config.c b/config.c
>> @@ -64,7 +64,8 @@ static void rewrite_credential_file(const char  
>> *fn, struct credential *c,
>>                 print_line(extra);
>>         parse_credential_file(fn, c, NULL, print_line);
>>         if (commit_lock_file(&credential_lock) < 0)
>> -               die_errno("unable to commit credential store");
>> +               die_errno("unable to write credential store: %s",
>> +                         strerror(errno));
>
> Hmm, this is already calling die_errno(), so adding another strerror()
> to the mix seems superfluous.
Oops, of course.
Show 14 quoted lines
>>  }
>>
>>  static void store_credential_file(const char *fn, struct credential *c)
>> diff --git a/fast-import.c b/fast-import.c
>> @@ -1824,7 +1824,7 @@ static void dump_marks(void)
>>
>>         dump_marks_helper(f, 0, marks);
>>         if (commit_lock_file(&mark_lock)) {
>> -               failure |= error("Unable to commit marks file %s: %s",
>> +               failure |= error("Unable to write file %s: %s",
>>                         export_marks_file, strerror(errno));
>
> Since you're already doing some normalization of the error messages
> with this patch, do you want to drop capitalization on this one?

The neighboring error messages are capitalized as well, as are many (but not all) other error and warning messages in fast-import.c.

SZEDER Gábor· Dec 3, 2015, 10:31 UTC · re: SZEDER Gábor · lore

[PATCH v2] Make error message after failing commit_lock_file() less confusing

The error message after a failing commit_lock_file() call sometimes looks like this, causing confusion:

  $ git remote add remote git@server.com/repo.git
  error: could not commit config file .git/config
  # Huh?!
  # I didn't want to commit anything, especially not my config file!

While in the narrow context of the lockfile module using the verb 'commit' in the error message makes perfect sense, in the broader context of git the word 'commit' already has a very specific meaning, hence the confusion.

Reword these error messages to say "could not write" instead of "could not commit".

While at it, include strerror in the error messages after writing the config file fails, to provide some information about the cause of the failure, and update the style of the error message after writing the reflog fails, to match surrounding error messages (i.e. no '' around the pathname and no () around the error description).

Signed-off-by: SZEDER Gábor <szeder@ira.uka.de>
---
Notes:
    Changes since v1:
    * Don't pass strerror() to die_errno().
 config.c           | 6 ++++--
 credential-store.c | 2 +-
 fast-import.c      | 2 +-
 refs.c             | 2 +-
 4 files changed, 7 insertions(+), 5 deletions(-)
Show changes to 4 files +7 −5

config.c, credential-store.c, fast-import.c, refs.c

diff --git a/config.c b/config.c
index 248a21ab94..86a5eb2571 100644
--- a/config.c
+++ b/config.c
@@ -2144,7 +2144,8 @@ int git_config_set_multivar_in_file(const char *config_filename,
 	}
 
 	if (commit_lock_file(lock) < 0) {
-		error("could not commit config file %s", config_filename);
+		error("could not write config file %s: %s", config_filename,
+		      strerror(errno));
 		ret = CONFIG_NO_WRITE;
 		lock = NULL;
 		goto out_free;
@@ -2330,7 +2331,8 @@ int git_config_rename_section_in_file(const char *config_filename,
 	fclose(config_file);
 unlock_and_out:
 	if (commit_lock_file(lock) < 0)
-		ret = error("could not commit config file %s", config_filename);
+		ret = error("could not write config file %s: %s",
+			    config_filename, strerror(errno));
 out:
 	free(filename_buf);
 	return ret;
diff --git a/credential-store.c b/credential-store.c
index 00aea3aa30..54c4e04737 100644
--- a/credential-store.c
+++ b/credential-store.c
@@ -64,7 +64,7 @@ static void rewrite_credential_file(const char *fn, struct credential *c,
 		print_line(extra);
 	parse_credential_file(fn, c, NULL, print_line);
 	if (commit_lock_file(&credential_lock) < 0)
-		die_errno("unable to commit credential store");
+		die_errno("unable to write credential store");
 }
 
 static void store_credential_file(const char *fn, struct credential *c)
diff --git a/fast-import.c b/fast-import.c
index e3b421d514..3c65edb5c4 100644
--- a/fast-import.c
+++ b/fast-import.c
@@ -1824,7 +1824,7 @@ static void dump_marks(void)
 
 	dump_marks_helper(f, 0, marks);
 	if (commit_lock_file(&mark_lock)) {
-		failure |= error("Unable to commit marks file %s: %s",
+		failure |= error("Unable to write file %s: %s",
 			export_marks_file, strerror(errno));
 		return;
 	}
diff --git a/refs.c b/refs.c
index 132eff52ca..b1c7b229b7 100644
--- a/refs.c
+++ b/refs.c
@@ -4684,7 +4684,7 @@ int reflog_expire(const char *refname, const unsigned char *sha1,
 					get_lock_file_path(lock->lk));
 			rollback_lock_file(&reflog_lock);
 		} else if (commit_lock_file(&reflog_lock)) {
-			status |= error("unable to commit reflog '%s' (%s)",
+			status |= error("unable to write reflog %s: %s",
 					log_file, strerror(errno));
 		} else if (update && commit_ref(lock)) {
 			status |= error("couldn't set %s", lock->ref_name);
-- 
2.6.3.420.g7bbb372
SZEDER Gábor· Dec 16, 2015, 11:22 UTC · re: SZEDER Gábor · lore

[PATCH] credential-store: don't pass strerror to die_errno()

Signed-off-by: SZEDER Gábor <szeder@ira.uka.de>
---

v2 fixed this, but it fell on the floor, I suppose because of the maintainer switch. Anyway, I should have noticed it while the patch was still cooking, sorry.

 credential-store.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
Show changes to credential-store.c +1 −2
diff --git a/credential-store.c b/credential-store.c
index fc67d16c1088..54c4e0473737 100644
--- a/credential-store.c
+++ b/credential-store.c
@@ -64,8 +64,7 @@ static void rewrite_credential_file(const char *fn, struct credential *c,
 		print_line(extra);
 	parse_credential_file(fn, c, NULL, print_line);
 	if (commit_lock_file(&credential_lock) < 0)
-		die_errno("unable to write credential store: %s",
-			  strerror(errno));
+		die_errno("unable to write credential store");
 }
 
 static void store_credential_file(const char *fn, struct credential *c)
-- 
2.7.0.rc0.37.g77d69b9
Jeff King· Dec 16, 2015, 18:20 UTC · re: SZEDER Gábor · lore

Re: [PATCH] credential-store: don't pass strerror to die_errno()

On Wed, Dec 16, 2015 at 12:22:55PM +0100, SZEDER Gábor wrote:
Show 6 quoted lines
> Signed-off-by: SZEDER Gábor <szeder@ira.uka.de>
> ---
> 
> v2 fixed this, but it fell on the floor, I suppose because of the
> maintainer switch.  Anyway, I should have noticed it while the patch
> was still cooking, sorry.

Oops. I do remember seeing Eric point out the problem and I think I was planning to fix it up before merging. But I didn't make a note in whats-cooking, so Junio had no idea of my plan.

>  credential-store.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
Patch is obviously correct. Thanks.
-Peff

← back to recent threads