I find it is so annoying to write submodule definition as follows (yeah, only url, without path)
------------------------------
[submodule 'crawler']
url = url1
[submodule 'search']
url = url2
------------------------------I think the following form is more simple
---------------------------------
[submodule]
crawler.url = url1
search.url = url2
---------------------------------So, could we support such simpler form?
-- Ping Yin