threads / patch / 12568

patchMinor wording changes in the keyboard descriptions in git-add --interactive.

Subject: [PATCH] Minor wording changes in the keyboard descriptions in git-add --interactive.

## tl;dr

4 messages between Mar 7, 2008 and Mar 13, 2008. Diffs are folded; open one to read it.

replies: 3people: 2as markdown or json

Vineet Kumar· Mar 7, 2008, 22:16 UTC · lore
There were some inconsistent mixing of "this hunk" and "that hunk" referring
to the same hunk; I switched them all to "this".  There was also a missing
"the".
---
 Documentation/git-add.txt |    8 ++++----
 1 files changed, 4 insertions(+), 4 deletions(-)
Show changes to Documentation/git-add.txt +4 −4
diff --git a/Documentation/git-add.txt b/Documentation/git-add.txt
index 4779909..bc74fc0 100644
--- a/Documentation/git-add.txt
+++ b/Documentation/git-add.txt
@@ -207,10 +207,10 @@ patch::
   and the working tree file and asks you if you want to stage
   the change of each hunk.  You can say:
 
-       y - add the change from that hunk to index
-       n - do not add the change from that hunk to index
-       a - add the change from that hunk and all the rest to index
-       d - do not the change from that hunk nor any of the rest to index
+       y - add the change from this hunk to index
+       n - do not add the change from this hunk to index
+       a - add the change from this hunk and all the rest to index
+       d - do not add the change from this hunk nor any of the rest to index
        j - do not decide on this hunk now, and view the next
            undecided hunk
        J - do not decide on this hunk now, and view the next hunk
-- 
1.5.3.7
Junio C Hamano· Mar 7, 2008, 23:47 UTC · re: Vineet Kumar · lore

Re: [PATCH] Minor wording changes in the keyboard descriptions in git-add --interactive.

Vineet Kumar <vineet@doorstop.net> writes:
Show 26 quoted lines
> There were some inconsistent mixing of "this hunk" and "that hunk" referring
> to the same hunk; I switched them all to "this".  There was also a missing
> "the".
> ---
>  Documentation/git-add.txt |    8 ++++----
>  1 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/Documentation/git-add.txt b/Documentation/git-add.txt
> index 4779909..bc74fc0 100644
> --- a/Documentation/git-add.txt
> +++ b/Documentation/git-add.txt
> @@ -207,10 +207,10 @@ patch::
>    and the working tree file and asks you if you want to stage
>    the change of each hunk.  You can say:
>  
> -       y - add the change from that hunk to index
> -       n - do not add the change from that hunk to index
> -       a - add the change from that hunk and all the rest to index
> -       d - do not the change from that hunk nor any of the rest to index
> +       y - add the change from this hunk to index
> +       n - do not add the change from this hunk to index
> +       a - add the change from this hunk and all the rest to index
> +       d - do not add the change from this hunk nor any of the rest to index
>         j - do not decide on this hunk now, and view the next
>             undecided hunk
>         J - do not decide on this hunk now, and view the next hunk

Hmm. Do we perhaps want to match this with the help text in "sub help_patch_cmd" of git-add--interactive.perl?

Vineet Kumar· Mar 10, 2008, 15:47 UTC · re: Junio C Hamano · lore

Re: [PATCH] Minor wording changes in the keyboard descriptions in git-add --interactive.

* Junio C Hamano (gitster@pobox.com) [080307 16:05]:
Show 31 quoted lines
> Vineet Kumar <vineet@doorstop.net> writes:
> 
> > There were some inconsistent mixing of "this hunk" and "that hunk" referring
> > to the same hunk; I switched them all to "this".  There was also a missing
> > "the".
> > ---
> >  Documentation/git-add.txt |    8 ++++----
> >  1 files changed, 4 insertions(+), 4 deletions(-)
> >
> > diff --git a/Documentation/git-add.txt b/Documentation/git-add.txt
> > index 4779909..bc74fc0 100644
> > --- a/Documentation/git-add.txt
> > +++ b/Documentation/git-add.txt
> > @@ -207,10 +207,10 @@ patch::
> >    and the working tree file and asks you if you want to stage
> >    the change of each hunk.  You can say:
> >  
> > -       y - add the change from that hunk to index
> > -       n - do not add the change from that hunk to index
> > -       a - add the change from that hunk and all the rest to index
> > -       d - do not the change from that hunk nor any of the rest to index
> > +       y - add the change from this hunk to index
> > +       n - do not add the change from this hunk to index
> > +       a - add the change from this hunk and all the rest to index
> > +       d - do not add the change from this hunk nor any of the rest to index
> >         j - do not decide on this hunk now, and view the next
> >             undecided hunk
> >         J - do not decide on this hunk now, and view the next hunk
> 
> Hmm.  Do we perhaps want to match this with the help text in
> "sub help_patch_cmd" of git-add--interactive.perl?

Yeah, personally I like those ones better; I think they're more readable. Any ideas on how to have them use the same source, or should I just duplicate the ones from git-add--interactive.perl into git-add.txt?

Vineet
-- 
http://www.doorstop.net/
Vineet Kumar· Mar 13, 2008, 18:32 UTC · re: Vineet Kumar · lore

The wording of the interactive help text from git-add--interactive.perl is clearer. Just duplicate that text here.

Signed-off-by: Vineet Kumar <vineet@doorstop.net>
---
 Documentation/git-add.txt |   18 ++++++++----------
 1 files changed, 8 insertions(+), 10 deletions(-)
Show changes to Documentation/git-add.txt +8 −10
diff --git a/Documentation/git-add.txt b/Documentation/git-add.txt
index 4779909..c751a17 100644
--- a/Documentation/git-add.txt
+++ b/Documentation/git-add.txt
@@ -207,16 +207,14 @@ patch::
   and the working tree file and asks you if you want to stage
   the change of each hunk.  You can say:
 
-       y - add the change from that hunk to index
-       n - do not add the change from that hunk to index
-       a - add the change from that hunk and all the rest to index
-       d - do not the change from that hunk nor any of the rest to index
-       j - do not decide on this hunk now, and view the next
-           undecided hunk
-       J - do not decide on this hunk now, and view the next hunk
-       k - do not decide on this hunk now, and view the previous
-           undecided hunk
-       K - do not decide on this hunk now, and view the previous hunk
+       y - stage this hunk
+       n - do not stage this hunk
+       a - stage this and all the remaining hunks in the file
+       d - do not stage this hunk nor any of the remaining hunks in the file
+       j - leave this hunk undecided, see next undecided hunk
+       J - leave this hunk undecided, see next hunk
+       k - leave this hunk undecided, see previous undecided hunk
+       K - leave this hunk undecided, see previous hunk
        s - split the current hunk into smaller hunks
        ? - print help
 +
-- 
1.5.4.2

← back to recent threads