threads / patch / 10732

patchgit-checkout: Add a test case for relative paths use.

Subject: [NEW REPLACEMENT PATCH] git-checkout: Add a test case for relative paths use.

## tl;dr

4 messages between Nov 8, 2007 and Nov 8, 2007. Diffs are folded; open one to read it.

replies: 3people: 3as markdown or json

David Symonds· Nov 8, 2007, 13:13 UTC · lore
Signed-off-by: David Symonds <dsymonds@gmail.com>
---
 t/t2008-checkout-subdir.sh |   47 ++++++++++++++++++++++++++++++++++++++++++++
 1 files changed, 47 insertions(+), 0 deletions(-)
 create mode 100755 t/t2008-checkout-subdir.sh
Show changes to t/t2008-checkout-subdir.sh +47 −0
diff --git a/t/t2008-checkout-subdir.sh b/t/t2008-checkout-subdir.sh
new file mode 100755
index 0000000..45b9e13
--- /dev/null
+++ b/t/t2008-checkout-subdir.sh
@@ -0,0 +1,47 @@
+#!/bin/sh
+#
+# Copyright (c) 2007 David Symonds
+
+test_description='git checkout from subdirectories'
+
+. ./test-lib.sh
+
+test_expect_success setup '
+
+	echo base > file0 &&
+	git add file0 &&
+	mkdir dir1 &&
+	echo hello > dir1/file1 &&
+	git add dir1/file1 &&
+	test_tick &&
+	mkdir dir2 &&
+	echo bonjour > dir2/file2 &&
+	git add dir2/file2 &&
+	git commit -m "populate tree"
+
+'
+
+test_expect_success 'remove and restore with relative path' '
+
+	cd dir1 &&
+	rm ../file0 &&
+	git checkout HEAD -- ../file0 && test -f ../file0 &&
+	rm ../dir2/file2 &&
+	git checkout HEAD -- ../dir2/file2 && test -f ../dir2/file2 &&
+	rm ../file0 ./file1 &&
+	git checkout HEAD -- .. && test -f ../file0 && test -f ./file1 &&
+	rm file1 &&
+	git checkout HEAD -- ../dir1/../dir1/file1 && test -f ./file1
+
+'
+
+test_expect_failure 'checkout with relative path outside tree should fail (1)' \
+	'git checkout HEAD -- ../file0'
+
+test_expect_failure 'checkout with relative path outside tree should fail (2)' \
+	'cd dir1 && git checkout HEAD -- ./file0'
+
+test_expect_failure 'checkout with relative path outside tree should fail (2)' \
+	'cd dir1 && git checkout HEAD -- ../../file0'
+
+test_done
-- 
1.5.3.1
Johannes Schindelin· Nov 8, 2007, 14:32 UTC · re: David Symonds · lore

Re: [NEW REPLACEMENT PATCH] git-checkout: Add a test case for relative paths use.

Hi,
just a few nitpicks:
On Fri, 9 Nov 2007, David Symonds wrote:
Show 8 quoted lines
> +test_expect_success setup '
> +
> +	echo base > file0 &&
> +	git add file0 &&
> +	mkdir dir1 &&
> +	echo hello > dir1/file1 &&
> +	git add dir1/file1 &&
> +	test_tick &&

please move the test_tick directly in front of the commit. Readers might assume that it has an effect on mkdir otherwise.

Show 6 quoted lines
> +	mkdir dir2 &&
> +	echo bonjour > dir2/file2 &&
> +	git add dir2/file2 &&
> +	git commit -m "populate tree"
> +
> +'

Please lose the empty line before the closing quote. (This applies to all tests.)

Show 16 quoted lines
> +test_expect_success 'remove and restore with relative path' '
> +
> +	cd dir1 &&
> +	rm ../file0 &&
> +	git checkout HEAD -- ../file0 && test -f ../file0 &&
> +	rm ../dir2/file2 &&
> +	git checkout HEAD -- ../dir2/file2 && test -f ../dir2/file2 &&
> +	rm ../file0 ./file1 &&
> +	git checkout HEAD -- .. && test -f ../file0 && test -f ./file1 &&
> +	rm file1 &&
> +	git checkout HEAD -- ../dir1/../dir1/file1 && test -f ./file1
> +
> +'
> +
> +test_expect_failure 'checkout with relative path outside tree should fail (1)' \
> +	'git checkout HEAD -- ../file0'

Maybe do that with an existing file? Since the test script lives in t/, and the test is run in t/trash/, we can test for "../Makefile".

Also, I would shorten the message to "relative path outside tree should fail".

> +test_expect_failure 'checkout with relative path outside tree should fail (2)' \
> +	'cd dir1 && git checkout HEAD -- ./file0'
I am not convinced that this should fail.
> +test_expect_failure 'checkout with relative path outside tree should fail (2)' \
> +	'cd dir1 && git checkout HEAD -- ../../file0'
Please add some other test like
test_expect_success 'checkout with empty prefix' '
	rm file0 &&
	git checkout HEAD -- file0 &&
	test base = "$(cat file0)"
'

Thanks, Dscho

Junio C Hamano· Nov 8, 2007, 20:48 UTC · re: Johannes Schindelin · lore

Re: [NEW REPLACEMENT PATCH] git-checkout: Add a test case for relative paths use.

Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
Show 9 quoted lines
>> +	mkdir dir2 &&
>> +	echo bonjour > dir2/file2 &&
>> +	git add dir2/file2 &&
>> +	git commit -m "populate tree"
>> +
>> +'
>
> Please lose the empty line before the closing quote.  (This applies to all 
> tests.)

I personaly find the extra blank lines before and after the indented test body easier to read. That is..

	test_expect_sucess 'test description comes here' '
		test command 1 &&
		test command 2 &&
                ...
                test command N
	'
I agree with all other suggestions from your message.
Johannes Schindelin· Nov 8, 2007, 23:04 UTC · re: Junio C Hamano · lore

Re: [NEW REPLACEMENT PATCH] git-checkout: Add a test case for relative paths use.

Hi,
On Thu, 8 Nov 2007, Junio C Hamano wrote:
Show 14 quoted lines
> Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
> 
> >> +	mkdir dir2 &&
> >> +	echo bonjour > dir2/file2 &&
> >> +	git add dir2/file2 &&
> >> +	git commit -m "populate tree"
> >> +
> >> +'
> >
> > Please lose the empty line before the closing quote.  (This applies to all 
> > tests.)
> 
> I personaly find the extra blank lines before and after the
> indented test body easier to read. 
Personally, I don't.  But you are the maintainer.

Ciao, Dscho

← back to recent threads