Re: [PATCH v2] tests: set temp variables using 'env' in test function instead of subshell
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 19, 2014, 17:28 UTC
- Message-ID
- <xmqqzjkm3xo1.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <20140318230658.GA10679@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 22 quoted lines
> On Tue, Mar 18, 2014 at 03:16:27PM -0700, Junio C Hamano wrote: > >> > Isn't GIT_CONFIG here another way of saying: >> > >> > test_must_fail git config -f doesnotexist --list >> > >> > Perhaps that is shorter and more readable still (and there are a few >> > similar cases in this patch. >> >> Surely, but are we assuming that "git config" correctly honors the >> equivalence between GIT_CONFIG=file and -f file, or is that also >> something we are testing in these tests? > > I think we can assume that they are equivalent, and it is not worth > testing (and they are equivalent in code since 270a344 (config: stop > using config_exclusive_filename, 2012-02-16). > > My recollection is that GIT_CONFIG mostly exists as a historical > footnote. Recall that at one time it affected all commands, but that had > many problems and was done away with in dc87183 (Only use GIT_CONFIG in > "git config", not other programs, 2008-06-30). I think we left it in > place for git-config mostly for backward compatibility,...
Thanks. Then I think it makes sense to do such a conversion but it probably should be done on top of this patch (we could do it before this patch), not as a part of this patch.